[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Bug in org-insert-link?

From: Guillaume MULLER
Subject: Re: Bug in org-insert-link?
Date: Mon, 4 Dec 2023 16:24:38 +0100
User-agent: Mozilla Thunderbird


Sorry for coming back that late on this problem. The problem came back again 
today: Links get inserted into random places again.

I think I have (the beginning of) an idea where problem lies.

- I'm using (Doom)Emacs in emacs-client mode, and I'm putting my computer only 
on sleep at night, so Emacs (daemon) often runs for weeks
- I regularly do some updates/upgrades: `sh> doom upgrade` or `sh> doom sync 
-u` (from shell, outside DoomEmacs)
  - Sometimes it works, so I just continue using Emacs
  - But sometimes doing the updates/upgrades while DoomEmacs is running make it 
go berserk
  - In such cases, I start by running `M-x doom/reload` (from inside Emacs), 
and if org buffers are going berserk too, I also run `M-x org-reload`
  - If it still does not work (most of the time), I `pkill emacs` and start 
Emacs again from scratch

The last time the link insertion issue appeared, I had called `M-x org-reload` 
after a `M-x doom/reload` after a `sh> doom upgrade`.

Restarting Emacs solved it.

I tried calling `M-x org-reload` and inserting some link on the fresh new Emacs 
process, and it seems to work.

So the problem apparently comes when calling `M-x org-reload` (from inside Emacs) 
after calling `sh> doom upgrade` (from outside Emacs). (NOTE: I haven't been 
able to try if the problem appears when calling `M-x doom/upgrade` (from inside 
Emacs) yet, as my Emacs is the freshest possible for now).

My conclusion is that "the bug" probably comes from the fact that the "org-mode" being 
reloaded is a fresher version than the "org-mode" that was loaded when Emacs-client was started, 
several weeks ago.

Not sure if this issue should be pursued or if my franken-usage of Emacs is to 
be blamed :)


On 10/9/23 16:40, Guillaume MULLER wrote:

Thanks for the answer... I'll have a look at your links.

However, since I wrote the email, I've seen the behavior occur without changing 
(at least voluntarily) the cursor position in the Org buffer...

On 10/5/23 12:18, Ihor Radchenko wrote:
Guillaume MULLER <guillaume.muller@emse.fr> writes:

- Switch back to (Doom)Emacs ("window"/desktop)
- Click inside the Emacs "window" to give it focus
[Here is the problem: sometimes I forgot that I already started the 
- Call org-insert-link
- Paste the URL
- Validate the link creation

Then the link is inserted where I clicked last (to give focus to the Emacs 

By default, Emacs moves point to where you click. You can do the same
thing if you deliberately C-x o from the minibuffer. See 9.3 Editing in
the Minibuffer section of Emacs manual.
I see nothing wrong on the Org side.

Of course, the problem lies in my mistake of calling twice the org-insert-link 
method, but the behavior is very strange, and it took me some time to identify 
why my links were inserted at random places in my text.

However, wouldn't it be possible to prevent it from the beginning by forbidding 
me to call org-insert-link twice, i.e. making it a singleton/atomic function (I 
don't see a UseCase where this could be useful to be able to call it inside 
itself, but maybe I'm wrong)?

Check out 22.1 Mouse Commands for Editing section of Emacs manual.
`x-mouse-click-focus-ignore-position' might be something you want to

Guillaume MULLER
Associate Professor, PhD
Fayol Institute - ISI Department
🚪 #426
☎ 04 77 42 02 71
🕸 https://www.mines-stetienne.fr
🧍= Physical Address =
  Espace Fauriel
  29 Rue Pierre et Dominique Ponchardier
  42100 Saint-Étienne
📬 = Postal Address =
  École des Mines de Saint-Étienne
  158 cours Fauriel
  42100 Saint-Étienne

Attachment: OpenPGP_0xF3BCAD9F46F5FADC.asc
Description: OpenPGP public key

Attachment: OpenPGP_signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]