fenfire-commits
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [ff-cvs] libvob/doc/pegboard/single_focus_manager--mudyc...


From: Tuomas Lukka
Subject: Re: [ff-cvs] libvob/doc/pegboard/single_focus_manager--mudyc...
Date: Sat, 6 Sep 2003 15:16:40 +0300
User-agent: Mutt/1.5.4i

Thank you ever so much for making this PEG!

Below, comments and corrections.

On Fri, Sep 05, 2003 at 09:35:53AM -0400, Matti Katila wrote:
> -.. Affect-PEGs:
> +The buoy oriented interface is in real use and must be stabilizer.

"stabilized", not "stabilizer".

> +Here are the proposal interface to be implemented by single manager.

Here are the proposed interfaces ...

Hmm, these are not all to be implemented by the manager -- are you again
not telling the truth? ;)

A better way of saying it would be "related to managing a single viewport with
buoys".

> +The term single manager means one focus view port which is arounded 
> +by buoy view ports.

(if you do it like that, this explaining is not needed)


>  Issues
>  ======
>  
> +- Method naming?

It usually pays to make the questions more explicit and exact.
This is a broad question that doesn't specify what is needed to answer it.

For example

- How should the method that does X in interface Y be named?
  fooBar or barFoo?

and only have those for the ones that you are uncertain of, or ones
that others have raised issues for.

>  Changes
>  =======
>  
> +The followin interface should be implemented:

"following", not "followin"

implemented - by whom? Or just defined?


> +
> +::
>  
> +    /** The manager for buoys and focus view ports.
> +     */

Like I said in another mail, this is not sufficient for understanding
the point of the class.

> +    public interface BuoyManager {
> +
> +        /** Folow the buoy link that is given. 

"Follow", not "folow"

> +         * BuoyManager implementation should interpolate 

*The* BuoyManager implementation...

> +         * the old buoy to main view port and 
> +         * old main view port to new buoy.
> +         */
> +        void followLink(Buoy buoy);

How about "moveFocusTo" sound for a name for this method?

> +        /** Draw the focus view port and buoys around it.
> +         * @param into The coordinate system where the focus is drawn.
> +         */
> +        void drawScene(VobScene vs, int into);

Is this true?

Is it the one where the focus is drawn, or the coordinate system surrounding 
the whole
focus + buoy thing out of which the geometers get their pieces?

> +        /** Returns the main node view.
> +         */
> +        BuoyViewMainNode getViewMainNode();

How about "getMainNode()"?

> +        /** Return the buoy if it's associated with this manager 
> +         * by given coordinate system, otherwise returns null.
> +         */
> +        Buoy getBuoy(int cs);
> +    }

Umm, how exactly does someone outside BuoyManager get this cs? 

Need to define what its relation to e.g. the "into" parameter to drawScene
is.


> +The Buoy class is one buoy floating around including these attributes:
> +
> +::
> +
> +    /** One instance of buoy hanging around buoy view managered by 
> BuoyManager.
> +     * @see BuoyManager
> +     */
> +    public class Buoy {
> +        public final BuoyViewNodeType buoyNode;

Bad name. How about "nodeType"?

> +        public final Object linkId, buoyAnchor;
> +        public final int buoyCS, direction;
> +
> +
> +        /** One buoy.
> +         * @param linkId The link identification of this buoy used in 
> interpolations.
> +         * @param buoyCS The coordinate system of this buoy.
> +         */
> +        public Buoy(BuoyViewNodeType buoyNode, Object linkId, 
> +             Object buoyAnchor, int buoyCS, int direction) {
> +             this.buoyNode = buoyNode;
> +             this.linkId = linkId;
> +             this.buoyAnchor = buoyAnchor;
> +             this.buoyCS = buoyCS;
> +             this.direction = direction;
> +        }
> +    }

Define "direction" and "buoyAnchor" better.

        Tuomas




reply via email to

[Prev in Thread] Current Thread [Next in Thread]