[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Freeipmi-devel] FreeBSD 5.4 / freeipmi 0.1.3 w/ Intel SE7210

From: Dmitry Frolov
Subject: Re: [Freeipmi-devel] FreeBSD 5.4 / freeipmi 0.1.3 w/ Intel SE7210
Date: Tue, 21 Jun 2005 13:36:13 +0700
User-agent: Mutt/1.5.6i

Anand, sorry for replying to You, but I didn't see original Mitch's

* Anand Babu <address@hidden> [21.06.2005 05:28]:

> ,----
> | As an aside, one thing I didn't see documented was the reason for
> | the prompt to use set_io (the name was longer - can't remember it,
> | and rerunning config does not ask the question again even after a
> | make distclean) vs. io (4)?

Applications that use i386_set_ioperm(2) on FreeBSD 5.x (and 6-current)
crash with SIGBUS sometimes, this is a known problem, but I don't
know if it's already fixed. So I will recommend to clear IOPERM
knob in port's configuration on FreeBSD 5.x. On 4.x one may use
either i386_set_ioperm(2) method or io(4) method.

Mitch, to rerun a configuration menu type "make config" in port's

> | I didn't see the option detailed in the PDF or anywhere else or any
> | details of what to choose or why / when?

This option pertains only to FreeBSD port, not to FreeIPMI itself.
Anyway the default (off for IOPERM) is safe, use it.

> ,----
> | I also tried building freeipmi on some older Intel STL2 systems
> | (FreeBSD 4.8) - to get it work work, I had to manually add port:
> `----
> Older Intel STL2 motherboards should use IPMI-1.0. I am glad it works.
> Please tell us the port number that worked for you. I will make the
> device detection code match it with product/manufacturer id and return
> this port internally.
> ,----
> | argp-standalone-1.3 And remove references to getopt.  FreeBSD uses
> | unistd, which seems to have been detected, but the separate
> | references to getopt were not removed - is this a configure bug?
> | Sorry I'm not a C coder
> | 
> | grep -r getopt.h *
> | vi work/freeipmi-0.1.3/bmc-watchdog/src/bmc-watchdog.c
> | vi work/freeipmi-0.1.3/ipmipower/src/ipmipower_config.c
> | vi work/freeipmi-0.1.3/libfreeipmi/src/ipmi-ping.c
> | 
> | I just dd'd the #include <getopt.h> lines.
> `----
> I did not know about this issue. GNU Coding Standards recommends argp
> library. Currently some tools uses argp library and some getopt. I
> think it is better to use argp uniformly through out the code base. We
> will take care of this bug in the next release. (Albert can you take
> care of this bug?)

Mitch, are you building FreeIPMI from port? It should deal with this.
It installs argp-standalone (and libgnugetopt on 4.x) as dependencies.

    wbr&w, dmitry.
Dmitry Frolov <address@hidden>
RISS-Telecom Network, Novosibirsk, Russia
address@hidden, +7 3832 NO WA1T, DVF-RIPE

reply via email to

[Prev in Thread] Current Thread [Next in Thread]