[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Freeipmi-devel] FreeIPMI on NetBSD (partial patch)

From: Ben C.
Subject: [Freeipmi-devel] FreeIPMI on NetBSD (partial patch)
Date: Sat, 13 Aug 2011 22:36:58 -0500

Apologies for the cross posing here, the freeipmi-devel@ mailing list
seems pretty dead.  I probably should of posted In freeipmi-users@ to
begin with.

I finally got it to compile using this patch I made myself (kind of,
thanks mostly to the NetBSD developer 'joerg' who wrote the asm*
functions, I'm pretty sure he did.)
In text:

However, it still doesn't work:

# bmc-config --checkout
could not find inband device

I've tried various drivers and devices although they were either
incorrect or freeipmi is broken in a way I do not understand nor how
to fix.  There was some messages on the mailing lists about NetBSD
support a year or two ago, -- I'm surprised it doesn't work 'out of
the box' already.

Anyone know the solution this time?

Thanks, Ben

On Sat, Aug 13, 2011 at 2:14 AM, Ben C. <address@hidden> wrote:
> Since there is no package in pkgsrc for FreeIPMI I have recently taken
> the task of building it the old fashioned way on my system.  I've had
> quite a few issues-but this one, I'm stuck at.  Right now my configure
> line looks something like this:
> ./configure LDFLAGS='-L/usr/pkg/lib/ -lpthread' CFLAGS='-I/usr/pkg/include/'
> Which ends with some errors (below).  The only thing I can find
> related are build errors associated with an entirely different
> architecture, ppc64.  Something about sys/io.h... glibc.. I'm really
> at a loss/over my head on this.  Any ideas? I've also pastebin'd the
> entire clean/configure/make log if anyone has a moment to help:
> Paste:
> Or, to view it without pastebin's ads, html, and other junk:
> Thanks, Ben
> -------
> [snip]
> *** Warning: Linking the executable bmc-config against the loadable module
> *** is not portable!
> libtool: link: gcc -I/usr/pkg/include/ -o .libs/bmc-config
> bmc-config.o bmc-config-argp.o bmc-config-channel-common.o
> bmc-config-map.o bmc-config-sections.o bmc-config-utils.o
> bmc-config-user-sections.o bmc-config-lan-channel-section.o
> bmc-config-serial-channel-section.o bmc-config-lan-conf-section.o
> bmc-config-lan-conf-auth-section.o
> bmc-config-lan-conf-security-keys-section.o
> bmc-config-lan-conf-misc-section.o
> bmc-config-lan-conf-user-security-section.o
> bmc-config-rmcpplus-conf-privilege-section.o
> bmc-config-serial-conf-section.o bmc-config-pef-conf-section.o
> bmc-config-sol-conf-section.o bmc-config-misc-section.o
> bmc-config-validate.o  -L/usr/pkg/lib/
> ../../common/src/configtool/.libs/libconfigtoolcommon.a
> ../../common/src/toolcommon/.libs/libtoolcommon.a
> ../../common/src/toolhostrange/.libs/libtoolhostrange.a
> ../../common/src/miscutil/.libs/libmiscutils.a
> ../../common/src/parsecommon/.libs/libparsecommon.a
> ../../common/src/portability/.libs/libfreeipmiportability.a
> ../../libipmidetect/src/.libs/
> ../../libfreeipmi/src/.libs/ -L/usr/pkg/lib
> /usr/pkg/lib/ /usr/pkg/lib/ -lintl
> -lpthread -lm -Wl,-rpath -Wl,/usr/local/lib -Wl,-rpath
> -Wl,/usr/pkg/lib
> ../../libfreeipmi/src/.libs/ undefined reference to `inb'
> ../../libfreeipmi/src/.libs/ undefined reference to `outb'
> *** Error code 1
> Stop.
> make: stopped in /root/freeipmi-1.0.4/bmc-config/src
> *** Error code 1
> Stop.
> make: stopped in /root/freeipmi-1.0.4/bmc-config
> *** Error code 1
> Stop.
> make: stopped in /root/freeipmi-1.0.4

reply via email to

[Prev in Thread] Current Thread [Next in Thread]