[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Freeipmi-users] ASUS IPMI card

From: Felix, Evan J
Subject: RE: [Freeipmi-users] ASUS IPMI card
Date: Fri, 10 Aug 2007 10:06:40 -0700

I had not as of yet setup other accounts, so I set one up using the
User3 config tools using the bmc_config program.  Before this I had used
the admin user on User2. I enabled the Capabilities you mentioned below.
Unfortunatly I still get the invalid username from the ipmipower and
ipmiconsole tools.  

In looking at the asus provided changes to the OpenIPMI stack they
provide this code to access a console:
# Set SOL Enable
./openipmicmd -k "0f 00 0c 21 01 01 01"          lan -U admin -P
$SOL_ADMIN_PASSWD -L admin -A rmcp+ -Ra rakp_hmac_sha1 -Ri hmac_sha1 -Rc
none $SOL_IP 623

# Activate Payload
./openipmicmd -k "0f 00 06 48 01 01 00 00 00 00" lan -U admin -P
$SOL_ADMIN_PASSWD -L admin -A rmcp+ -Ra rakp_hmac_sha1 -Ri hmac_sha1 -Rc
none $SOL_IP 623

# Set SOL Baud Rate
./openipmicmd -k "0f 00 0c 21 01 05 $SOL_BAUD_RATE_TYPE"          lan -U
admin -P $SOL_ADMIN_PASSWD -L admin -A rmcp+ -Ra rakp_hmac_sha1 -Ri
hmac_sha1 -Rc none $SOL
_IP 623

# Start SOL console
./solterm lan -U admin -P $SOL_ADMIN_PASSWD -L admin -A rmcp+ -Ra
rakp_hmac_sha1 -Ri none -Rc none -bitrate=$SOL_BAUD_RATE $SOL_IP

# Set SOL Disable
./openipmicmd -k "0f 00 0c 21 01 01 00"          lan -U admin -P
$SOL_ADMIN_PASSWD -L admin -A rmcp+ -Ra rakp_hmac_sha1 -Ri hmac_sha1 -Rc
none $SOL_IP 623

# Deactivate Payload
./openipmicmd -k "0f 00 06 49 01 01 00 00 00 00" lan -U admin -P
$SOL_ADMIN_PASSWD -L admin -A rmcp+ -Ra rakp_hmac_sha1 -Ri hmac_sha1 -Rc
none $SOL_IP 623

Are the SOL Enable/Disable commands sent by the ipmipower tool, or the
Deactivate Payload commands?

Using the bmc-config tool, my SOL_Conf section is completely blank.


> -----Original Message-----
> From: Al Chu [mailto:address@hidden 
> Sent: Friday, August 10, 2007 9:17 AM
> To: Felix, Evan J
> Cc: address@hidden
> Subject: Re: [Freeipmi-users] ASUS IPMI card
> Hey Evan,
> I worked w/ Asus a few months back on some "sanity" checking 
> if FreeIPMI worked with their motherboards.  Although there 
> were some nit-IPMI compliance complaints, they reported it 
> worked fine (of course who knows what motherboard/firmware 
> version they worked on).
> Anyways, if you are getting username invalid errors, it's 
> usually typical of the remote BMC not being configured 
> correctly.  I take it you configured several new usernames?  
> Did you turn on "Enable_User", and "Lan_Enable_IPMI_Msgs" and 
> setup an appropriate "Lan_Privilege_Limit"
> for the user?
> Al
> On Fri, 2007-08-10 at 09:04 -0700, Felix, Evan J wrote:
> > Has anyone worked with the ASUS ASMB3 IPMI management card 
> on ASUS motherboards.  Many of the uilities work, but some of 
> them just return a username invalid when you use them.  The 
> bmc-config utility works fine locally.  The ipmi-sensors and 
> impi-chassis seem to work fine.  The ipmi-power, and 
> ipmi-console error out with a username invalid.  The 
> ipmiconsole also does this. 
> > 
> > So, Anybody used this card with freeipmi, and any 
> suggestions on how I can figure out what it is doing. 
> > 
> > I do know that the utility that asus provides as a modified 
> OpenIPMI tarball uses rcmp+ commands to connect as the console.
> > 
> > Evan
> > 
> > _______________________________________________
> > Freeipmi-users mailing list
> > address@hidden
> >
> > 
> --
> Albert Chu
> address@hidden
> 925-422-5311
> Computer Scientist
> High Performance Systems Division
> Lawrence Livermore National Laboratory

reply via email to

[Prev in Thread] Current Thread [Next in Thread]