[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Freeipmi-users] Problem pasting data into ipmiconsole

From: Albert Chu
Subject: Re: [Freeipmi-users] Problem pasting data into ipmiconsole
Date: Fri, 27 Jun 2014 10:23:15 -0700

Hi David,

Lets see on line 1001, we see the packet that is being sent w/ your
data.  You can see in the character_data buffers lots of "20h 30h" hex,
which is ascii spaces and 0's.

As you deduced properly, the remote BMC is nacking the packet.
According to the IPMI spec, "the BMC is unable to accept all character
data from this packet."

Well that sucks.  It seems the Dell BMC just can't handle that much
simultaneous data being sent.  I tried this on some motherboards I have
locally that are not Dells and these BMCs were able to handle much
larger cut & pastes with ease.

We could program a workaround/option into ipmiconsole/libipmiconsole
that could max-cap the number of characters a "SOL Remote Console to
BMC" packet is allowed to send at the same time, to alleviate this
situation for your BMC.  libimiconsole could even be smart enough to
recognize when too many NACKs happen in a row and try to decrease the
characters sent in one packet, although I'm not sure how hard that would
be to program right now.  It's a bit more sophisticated and would take
time, but the workaround option would be much easier.


On Fri, 2014-06-27 at 12:04 +1000, David O'Shea wrote:
> Hi all,
> With version 1.2.1-6.el6_5 RPM from CentOS 6, when I ran 'ipmiconsole'
> and pasted in a fairly small amount of data (maybe 15 or so
> characters), I got "[error received]: excess retransmissions sent".  I
> got a similar issue when writing about that much data from a Python
> script using libipmiconsole.  I figured this means I should move on to
> a newer version.
> With version 1.4.3, which I built from source with debugging enabled,
> it seems like I need to paste a bit more data to trigger problems.  In
> this case, I don't get an error like the above, instead things just
> seem to get "stuck": I never seem to get a response from the remote
> system, but sending an escape sequence still works.
> I started ipmiconsole, pasted " 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
> 0 0 0 0 0 0 0 0" (54 characters long), then after a few seconds I used
> ".." to terminate:
> """
> $ [...]/freeipmi-1.4.3/ipmiconsole/ipmiconsole -h hostname -u admin -p calvin 
>  -e . --debug --debugfile
> [SOL established]
> [closing the connection]
> """
> The target is a Dell iDRAC7 with firmware version 1.56.55.
> I put some of the log file that was generated up at
> (after replacing
> the hostname with "hostname").  If you go to line 889
> [],
> this seems to be the part that relates to when I pasted in the text.
> It seems that ipmiconsole keeps re-sending the data and the iDRAC
> keeps responding with NACKs.  The entire log contains 2000 of these
> messages:
> (ipmiconsole_processing.c, _sol_bmc_to_remote_console_packet, 2672): 
> hostname=hostname; protocol_state=9h: SOL packet NACKED: 
> accepted_character_count: accepted_character_count = 0,  
> c->session.sol_input_character_data_len = 54
> Thanks in advance,
> David
> _______________________________________________
> Freeipmi-users mailing list
> address@hidden
Albert Chu
Computer Scientist
High Performance Systems Division
Lawrence Livermore National Laboratory

reply via email to

[Prev in Thread] Current Thread [Next in Thread]