[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Freeipmi-users] Troubleshooting inconsistent results from server

From: Brian LaFlamme
Subject: Re: [Freeipmi-users] Troubleshooting inconsistent results from server
Date: Fri, 8 Jan 2016 14:23:54 -0500

On Fri, Jan 8, 2016 at 1:08 PM, Albert Chu <address@hidden> wrote:

> On Fri, 2016-01-08 at 09:22 -0500, Brian LaFlamme wrote:
> > For the over-LAN issue, I cannot ipmiping node1, but I can ipmiping
> > node2.  This is the same flat network with no firewalls or other
> > devices in between.  Also, for both nodes, the web system management
> > console works just fine.
> The web console is independent of IPMI.  It's possible that IPMI over
> LAN isn't enabled on your motherboard.  Once the inband issue is
> resolved, you can take a look into the bmc-config output to see if
> anything looks wrong.
> Some Dell motherboards also require some configuration in the BIOS.  You
> may want to take a look in there.  Also, on motherboards with multiple
> NICs, often ethernet has to be plugged into the right NIC(s).
Fixed the inband issue (see below).  Regarding the over-LAN problems, I see
no signs of any trouble from the config.  Only difference between node1
(not working over lan) and node2 (working over lan) is the IP and MAC

address@hidden:~# bmc-config --diff -v --filename=new_bmc_config_node2
Lan_Conf:IP_Address - input=`':actual=`'
Lan_Conf:MAC_Address - input=`00:A0:D1:ED:92:3A':actual=`00:A0:D1:ED:90:F7'

I'll check all the other basics for networking and BIOS settings and report

> >
> > For the inband issue, it appears that I do have local kernel support
> > on node1:
> >
> >
> > address@hidden:/etc# ps aux | grep ipmi
> > root         237  0.1  0.0      0     0 ?        SN   Jan06   4:41
> > [kipmi0]
> >
> >
> > And this appears to be built directly into the kernel.  I found no
> > modules associated with ipmi.  From the link you set, it looks like
> > adding should work, right?
> >
> >
> > ipmi_si.force_kipmid=0
> Looks like that would work.  The staff at my company just solved this by
> starting/creating the /dev/ipmi0 device.

I just loaded the modules using modprobe, and then everything worked
locally.  A surprisingly simple fix for inband, but now to troubleshoot the

reply via email to

[Prev in Thread] Current Thread [Next in Thread]