[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gcl-devel] Problems building GCL on Mac Os X

From: Lorenzo Costanzia di Costigliole
Subject: Re: [Gcl-devel] Problems building GCL on Mac Os X
Date: Wed, 14 Mar 2007 15:17:17 +0100


I did the a 'cvs update' on March 7th and haven't tried building again since then. I'm running Mac OS X 10.4.8 aka "powerpc-apple-darwin8.0" (uname -a shows "Darwin (...) 8.8.0 Darwin Kernel Version 8.8.0: Fri Sep 8 17:18:57 PDT 2006; root:xnu-792.12.6.obj~1/RELEASE_PPC Power Macintosh powerpc")

I started the build process under a zsh (4.2.3), but the configure script is executed by sh("2.05b.0(1)-release"), I've tried also building without /sw (fink) in the PATH, (which is known for causing problems).

In line 4936 configure checks for "ldd" which doesn't exist in Darwin (-> `which ldd` gives "ldd not found"), its corresponding tool is called "otool -L". I have no idea why test -x fails, when executing it in an interactive shell it works.

Please look also at my other posts! Do you think the other errors described there could be a consequence of this configure error?

Thank you for your response

--On 13. März 2007 19:04:49 -0400 Camm Maguire <address@hidden> wrote:

Greetings!  configure apparently had an error in your shell:

checking CSTACK_DIRECTION... -1
checking for shared library/C stack ceiling to heap... ./configure: line
4936: test: too many arguments 0x0
checking for maxpage revision... 0

Which version of gcl is this?  Which OS?  Which shell?  Can you
diagnose the failure so we can fix it?

Take care,

Camm Maguire                                            address@hidden
"The earth is but one country, and mankind its citizens."  --  Baha'u'llah

Attachment: pgpb4_tbF5buJ.pgp
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]