[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Gcl-devel] info files

From: Camm Maguire
Subject: [Gcl-devel] info files
Date: Thu, 07 Apr 2011 13:08:06 -0400
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.2 (gnu/linux)

Greetings!  Can you confirm that this is an issue of the missing
gcl.info, and not munged gcl-si.info or gcl-tk.info?  We cannot ship
the former in official releases alas as the draft dpANS doc does not
have a compatible license per FSF.  Wish therre was a resolution to

Take care,

Donald Winiecki <address@hidden> writes:

> Hi Camm,
> All worked well with the info files when first set up 2.6.8 pre on my
> machine last August.
> I don't believe it is the build but rather the files themselves --
> they appear to be munged on the server.  When I copy the info files I
> archived last summer into an appropriate directory path, they work
> fine...
> Best,
> _don
> On Mon, Apr 4, 2011 at 9:31 AM, Camm Maguire <address@hidden> wrote:
>> Greetings, and thanks for the great news of your report!
>> I concur that the most likely explanation of your results is a
>> vistafication of your xp boxes.  In any case, clearly a build tool
>> issue outside of gcl's control, now thankfully resolved, apparently.
>> All that remains apparently is your info issue.  Here is what I get in
>> a freshly built tree after a successful (help 'cons):
>> ("/home/camm/debian/gcl/gcl-2.6.8pre/info/" "/" "/usr/info/"
>>  "/usr/local/lib/info/" "/usr/local/info/" "/usr/local/gnu/info/"
>>  "/usr/share/info/")
>> The path (concatenate 'string si::*lib-directory* "info") should be
>> prepended to si::*info-paths* at first invocation of the info system.
>> If you could report your results, we can see why this is not happening
>> for you.  Please note that when installing a built tree elsewhere, the
>> utility function si::reset-sys-paths must be used to get things in
>> sync in their new locations.  The Debian gcl package does this
>> automatically.  make install should too, but if you are building a
>> windows installer, then I really don't know what is right.
>> Really close now!
>> Take care,
>> Donald Winiecki <address@hidden> writes:
>>> Hi all!
>>> Over the past several weeks I have been working to create a native
>>> WinXP (32 bit) build of the current gcl268pre.  Up until last night I
>>> had been unsuccessful on four separate machines running WinXP either
>>> natively or under emulation (through Sun's/Oracle's VirtualBox).
>>> Building the CLtL1 variant had never been a problem.
>>> I was finally successful after installing the build tools following my
>>> directions for preparing to build GCL on WinVista.  I have tried and
>>> had success on three of the four machines that previously failed a
>>> gcl268pre-ANSI build (I haven't yet tried on the fourth machine).
>>> Paranoid as I am, I normally keep all Windows operating systems up to
>>> date with patches from Microsoft and right now I'm guessing (and it's
>>> just that, a guess) that some recent patches from Microsoft for WinXP
>>> have put code or operating characteristics from WinVista into WinXP.
>>> This may (hypothetically) account for my inability to build
>>> gcl268pre-ANSI natively on an up-to-date installation of WinXP.
>>> But even with this, I and one other user have experienced trouble
>>> getting the current *info* file package to operate inside the GCL
>>> REPL.  It would always complain about broken access to the info
>>> file(s).  At the very bottom of this message is the result of
>>> attempting to invoke (help 'cons) from the REPL.
>>> HOWEVER, I was successful in getting the info files to operate inside
>>> the REPL by copying info files from a several-month-old installation
>>> of GCL on another machine, into the proper directory structure and
>>> replacing the info files currently posted on the GCL project's
>>> website.
>>> The info files currently posted on the GCL project's website do not
>>> extract properly.  When extracting the files, I receive an error
>>> "There are data after the end of archive" (I'm using the open source
>>> version of 7-zip to extract them on my WinXP machine). Perhaps others
>>> could confirm this for me in their installations of GCL and if we get
>>> reliable failures, we can replace the currently posted info files with
>>> my archived copy.
>>> Best,
>>> -- documentary trace of failure of (help 'cons) --
>>>>(help 'cons)
>>> -----------------------------------------------------------------------------
>>> CONS                                                               
>>> [Function]
>>> (not found "dir")
>>> Error in IF [or a callee]: Cannot open the file NIL.
>>> Fast links are on: do (use-fast-links nil) for debugging
>>> Broken at SYSTEM::PRINT-DOC.  Type :H for Help.
>>>  1 (Continue) Retry opening file #p"NIL".
>>>  2 (Abort) Return to top level.
>>> dbl:>>
>>> -- end --
>>> _don
>>> ~~~~~~~~~~~~~~~~~~~~~~~~~
>>> Don Winiecki, Ed.D., Ph.D.
>>> Professor
>>> Boise State University, College of Engineering
>>> Department of Instructional & Performance Technology
>>> 1910 University Drive, Boise, Idaho 83725-2070 USA
>>> E-mail: address@hidden
>>> WWW: http://ipt.boisestate.edu
>>> Telephone: (+01) 208 426 1899
>>> Fax: (+01) 208 426 1970
>>> ~~~~~~~~~~~~~~~~~~~~~~~~d
>> --
>> Camm Maguire                                       address@hidden
>> ==========================================================================
>> "The earth is but one country, and mankind its citizens."  --  Baha'u'llah
> _______________________________________________
> Gcl-devel mailing list
> address@hidden
> http://lists.gnu.org/mailman/listinfo/gcl-devel

Camm Maguire                                        address@hidden
"The earth is but one country, and mankind its citizens."  --  Baha'u'llah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]