[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gNewSense-users] help!! wireless misery with Linksys WUSB54G ver.4

From: Guy Johnston
Subject: Re: [gNewSense-users] help!! wireless misery with Linksys WUSB54G ver.4
Date: Thu, 22 Mar 2007 21:16:28 +0000
User-agent: Thunderbird (X11/20070306)

andrei raevsky wrote:
> Hi friends,
> Once, only one time, the Linksys WUSB54G USB wireless adaptor worked on
> my computer with gNewSense.  Ever since, every time I try it freezes up
> the entire system (so I suspect a kernel panic).  The only time it
> worked I used ndiswrapper and the win32 drivers, but now it does not
> work with that either.  This particularly frustrating since the Linksys
> WUSB54G is recommended by the FSF are working with free software (and
> since they use gNewSense, that means it should work on my updated
> gNewSense also).
> My kernel is (according to 'uname -a'):
> Linux gNewSenseBox2 2.6.15-28-386 #1 PREEMPT Fri Feb 9 20:06:14 UTC 2007
> i686 GNU/Linux
> The version of the Linksys WUSB54G I use is ver. 4
> Also - I do not have wireless at home so I can only test when I go out. 
> And since each re-boot takes about 5min on my old machine, you can
> imagine how time consuming trying to fix this is.
> Also - I tried with Ubuntu 6.06 to see what would happen.  It freezes
> *exactly* at the same time as gNewSense does: I open the network
> configuration interface, It sees the adapter and it loads a driver, then
> I press 'activate connection' and after 1-2 seconds everything freezes.
> I really, really would appreciate some step by step advice to make this
> @^#%$!! device to work!
> Thanks in advance for any pointers,
> Andrei
> ------------------------------------------------------------------------
> _______________________________________________
> gNewSense-users mailing list
> address@hidden

I've got that exact same card. I used to have some problems with it but
I've now got it working fine out of the box with gNewSense 1.1. My
kernel version is exactly the same as yours. Someone was asking about it
a while ago. I've included my response to that below, which might help.
I also find that it cause the system to crash when trying to connect
with the default driver, but putting in the 'sleep' commands in the
script I use (see below) seems to stop that happening. I think it might
also help if you download and compile the driver from the website, as it
seems to work a bit better than the default one.

I was having problems with that driver before, but I've now got it
working properly out of the box with gNewSense 1.1. I'm using it in
Managed mode, with WPA (TKIP encryption), using DHCP to get the IP
address. Unfortunately I can't get it working using any
graphical programmes, but I've made a shell script which I just have to
run. It connects properly more or less every time I run it. It
occasionally disconnects after a while, so I have to run it again, but
not very often. Here it is:

sudo iwpriv rausb0 enc 3
sleep 1
sudo iwpriv rausb0 auth 3
sudo iwconfig rausb0 essid "*** ****** ***** ** ***"
sudo iwpriv rausb0 wpapsk **************
sudo iwconfig rausb0 essid "*** ****** ***** ** ***"
sleep 1
sudo ifconfig rausb0 up
sleep 1
sudo iwpriv rausb0 enc 3
sleep 1
sudo iwpriv rausb0 auth 3
sudo iwconfig rausb0 essid "*** ****** ***** ** ***"
sudo dhclient rausb0

I got this by looking at various scripts people had on the driver forums
 , in the various topics about WPA.

You need to replace the stars with your ESSID and WPA key as
appropriate. It seems that you don't need the quotation marks for the
WPA key, but you do for the ESSID if it has spaces in. The 'sleep 1'
lines just create 1 second pauses. It works without them, but using them
seems to make it less likely to disconnect later. In some of the scripts
I looked at, the 3rd pause was 10 seconds long ('sleep 10'), so that
might be helpful as well.

I've got version 4 of the card, which is the only one specifically
recommended by the FSF, because it uses the RT2500 chipset (which runs
using the RT2570 driver with USB cards). I don't know which chipset any
of the other versions use, and whether or not they run on gNewSense
using only free (as in freedom) software.


Please avoid sending me Microsoft Office files - see
Don't get Windows Vista, get GNU/Linux - see

reply via email to

[Prev in Thread] Current Thread [Next in Thread]