[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gNewSense-users] Request for file permission help.

From: Kevin Dean
Subject: Re: [gNewSense-users] Request for file permission help.
Date: Wed, 5 Sep 2007 11:29:48 -0400

Personally, as easy as it supposedly makes migration, I've found from
experience that migrating /home across distros, or even installs of
the same distro, almost always fails. ;(

I've begun tarballing my files and moving them; permission preserved
and system settings (anything not pretaining ot my "theme", for
instance) set by the distro to avoid conflicts.

As to your specific problem, I'm not sure... It appears as if you're
covering your bases, but perhaps the chmod isn't affecting .* files?

cd /home; chown -R chris:chris /home/chris/.*; chmod -R u+rw /home/chris/.*; ?

On 9/5/07, Chris Andrew <address@hidden> wrote:
> Hi, guys.
> I rebuilt my main PC, today.  Feisty has gone and gNS is up and
> running.  I have copied all my old data to the newly carved-up drives,
> but am getting some permissions problems.  I have done this before,
> but can't remember how I solved it.
> Basically, the problem is with logging-in and the permissions on /home
> directories and files.
> I have done:
> chown -R chris 770 (I am user chris)
> chgrp -R chris 770
> chmod -R /home/chris
> When I log out and log back in, I get a Gnome message telling me that
> my $HOME/.dmrc has the wrong permissions and should be 644.  I have
> changed this, but still the same error.
> Basically, I don't want my files to be world readable (read as home
> readable!).  All users should own the files in their $HOME, and
> finally, I need to get rid of the Gnome message.
> Can anyone put me straight?
> Cheers
> Chris.
> --
> Reasons why you may want to try GNU/Linux:
> A great GNU/Linux distro:
> _______________________________________________
> gNewSense-users mailing list
> address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]