[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gNewSense-users] Stupid question- 64 bit.

From: Bake Timmons
Subject: Re: [gNewSense-users] Stupid question- 64 bit.
Date: Wed, 05 Mar 2008 17:52:07 -0500
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.0.60 (gnu/linux)

> Just built a new AMD 64 bit machine.  No CDROM yet, so can't try the
> usual install ISO.  My stupid question, will gNS  exist happily on AMD
> 64?

I just built the same thing recently--perhaps your system might have
similar issues.  Although I too have no CD-ROM drive (and frankly cannot
justify ever paying for that which I have little use), I installed from
the ISO anyway via qemu.  I just hooked up the new drive in the old
system, made an initial partition, and using software RAID(*), mounted
the same partition under a qemu booting from the ISO.  I then installed
gNS and rebooted with the new partition *under qemu* since my new
equipment will hang on the kind of ancient kernel from the ISO.

Then I installed any missing compiling tools that I would need anyway,
compiled and configured a recent kernel such as 2.6.24 for my new AMD
system, and installed it onto the partition.  After shutting down qemu
and then the old system, I installed the drive into the old system and
boot.  It hung a few times before I realized that I needed a special
boot option.  Here is the interesting part from my /boot/grub/menu.lst

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
##      kopt_2_6_8=root=/dev/hdc1 ro
##      kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=/dev/sda1 ro clocksource=acpi_pm

After putting in that clocksource=acpi_pm option, I ran update-grub,
which fixed the menu entries.  Of course, in order to get to that point
of not hanging, I first needed to do a manual, temporary, edit of the
boot line when grub started.

After that, I really had no special problems, just some tweaking and
what not.  It may sound like a bit much, but it was a nice exercise in
exploiting the unparalleled flexibility of free software.  Just ask if
there are any problems, and have fun.

Other issues:

1.  The 2.6.24 kernel of course has non-free code, so I plan on using one
of the "blagged" kernels until a proper gNS solution is here.

2.  My intel-hda sound was not recognized by the ancient ALSA software
in gNS, so I fixed it by installing the latest ALSA.  However, I think I
am OK in this case, since it seems that the driver does not involve
non-free code.

3.  Of course, 690G video under gNS is bad, so I have resorted to the
brain-dead vesa driver and needing to manually turn off the CRT since
the DPMS does not work.  Yet another reason to celebrate a new upcoming
version of gNS.

(*)RAID/qemu trick: See

reply via email to

[Prev in Thread] Current Thread [Next in Thread]