[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gNewSense-users] Tangogps

From: Tor at Shared Genius
Subject: Re: [gNewSense-users] Tangogps
Date: Wed, 29 Apr 2009 09:51:41 -1000
User-agent: Thunderbird (X11/20090318)

Niklas Cholmkvist wrote:
I've tried to compile the tangogps version 0.9.6 by reading the
INSTALL text file that comes with it.

1. ./configure . I think everything went fine.

2. make . "make: *** [all] Error 2" in the end. I got more errors
before like: "tile_management.c:268: error: ‘CURLOPT_FAILONERROR’
undeclared (first use in this function)"

Has anyone of you managed to make tangogps work?

I haven't tried myself, but this is likely due to some -dev packages that you need to install in order to get it to compile, because apparently configure can't always distinguish between the main binary and the -dev package needed to compile against the package. Look in the documentation for what they are; on gNewSense they usually are called $PACKAGENAME-dev.

This information is probably in either README or INSTALL, although often because the maintainers need compatibility with all distros the naming convention of some of the packages may not be exactly right.

It may even tell you just above the error what package that error is caused by, although I would guess that you need the curl -dev package to solve this particular one.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]