[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gNewSense-users] Autodetect Screen Resolution

From: Jason Self
Subject: Re: [gNewSense-users] Autodetect Screen Resolution
Date: Mon, 13 Jul 2009 21:52:57 -0700

On Mon, Jul 13, 2009 at 9:36 PM, Jason Self<address@hidden> wrote:
> On Mon, Jul 13, 2009 at 9:24 PM, Jason Self<address@hidden> wrote:
>> On Mon, Jul 13, 2009 at 3:10 PM, Sam Geeraerts<address@hidden> wrote:
>>> Jason Self schreef:
>>>> I can't see to get my monitor to run at full resolution. (I seem to be
>>>> stuck at 1600 x 1200 even though the max should be 1920 x 1200.)
>>>> To provide some background, what I'm working with is an ASUS
>>>> EAH3450/DI/256M Radeon HD 3450 256MB 64-bit GDDR2 PCI Express 2.0 x16
>>>> HDCP Ready CrossFire Supported Low Profile Ready Video Card.
>>>> My research indicates that the Radeon HD 3450 is considered RV620 and
>>>> needs the radeonhd driver to run at full resolution. So I run sudo
>>>> aptitude install xserver-xorg-video-radeonhd and obtained version
>>>> 1.1.0-1.
>>>> My research indicates that Ubuntu 8.04 (on which gNewSense is based)
>>>> uses autodetects hardware:
>>>> so it seems that X should now auto detect the radeonhd driver, but I'm
>>>> still stuck at 1600 x 1200 even after a full system restart.
>>>> I've also tried sudo dpkg-reconfigure -plow xserver-xorg but was never
>>>> prompted for which driver to use.
>>>> I've run out of ideas and I'm hoping that someone might have some input.
>>>> A copy of my xorg.conf can be found at
>>>> A copy of my X log can be found at
>>> X has come a long way, but my experience is that it's still far from
>>> perfect. It seems that in your case it's still using the vesa driver. Try
>>> changing your xorg.conf Device section to:
>>> Section "Device"
>>>        Identifier      "Configured Video Device"
>>>        Driver          "radeonhd"
>>> EndSection
>> Thank you. I attempted that. After rebooting a message appeared
>> stating that the system was booting into low resolution mode. The X
>> log file is Hmmm....
> I think that I may have found the cause:
> Remembering that sudo aptitude install xserver-xorg-video-radeonhd
> gave me version 1.1.0, it looks like support for my RV620 wasn't added
> until after that.
> So it appears that I need a newer version of radeonhd. I'll go & try that.

I just wanted to post that the newer version did indeed work for me. I
compiled the latest version (1.2.5 as of right now), but X still
didn't autoconfigure itself so I still had to include this in my X
config file.

Section "Device"
       Identifier      "Configured Video Device"
       Driver          "radeonhd"

I don't really care to bypass the package manager, but it's so much
nicer to have my LCD panel run at full resolution.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]