[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gNewSense-users] Launchpad licensed under AGPL v3.0: Consequences

From: Nicodemo Alvaro
Subject: Re: [gNewSense-users] Launchpad licensed under AGPL v3.0: Consequences for gNS?
Date: Wed, 22 Jul 2009 23:09:47 +0500

On 7/22/09, Eric Morey <address@hidden> wrote:
> On Wed, 2009-07-22 at 05:25 +0500, Nicodemo Alvaro wrote:
>> I've heard that Launchpad has the license notice AGPL v3, as in not
>> your option to use a later version.
> Yes, you are correct. See the license file on the current stable branch:
You must check the license notice, which is inside the source code.
Here is an example:

That license you linked to all the way at end explains how to apply
the license in a similar fashion. It is often you will find that some
people do not place a license notice in the source code, this makes it
uncertain what license is actually and originally used in. Sometimes,
you will see people refuse to place the "(or at your option) any later
version" in the license notice and is what Launchpad has. This is
problematic, because we are dependent on the Canonical to update the
license in the event of new license upgrades so that we can copy the
source code from their project to the savane-cleanup project, which I
posted a link to above. If we are to take advantage of our freedoms we
should be allowed to copy the code and be sure we can use it for later

There is a compatibilty chart that helps to explain the problem.

I was in IRC just now, and here is a summary of the Savannah Admins' concerns.

1) it's centered on a unique VCS
2) it has a different (but more flexible) user/groups models that is
not easy to migrate to and
3) it's still in early stage, maybe it will be cleaned-up later but
right now it's a bit messy (ubuntu 8 only, etc.)
4) Savannah may be integrating with Pootle instead of Rosetta.
5) Usability is not that great.

>> I've  had problems retrieving the source code, because they are using
>> a newer version of bazaar, which is incompatible with my version 1.3.
>> Canonical claims their code to be written with Hardy and Jaunty, but I
>> could find no other bzr version in their package lists or gNewSense
>> deltah.
> You may have missed from
>> Note that right now, Launchpad can only be built and run on Ubuntu
>> (8.04 "Hardy" to 9.04 "Jaunty")...
>> //Overview//

Come on now, overview is a horrible place to have instructions.

>> ...Launchpad's branches are hosted in Bazaar [1], using the most
>> up-to-date repository format available. That means you'll need to use
>> at least Bazaar 1.16.1 [2] to get Launchpad -- and please consider
>> using 1.17 [3], which has just been released. Packages are also
>> available in the Bazaar PPA[4]
Yes, but the end result does not look like a valid solution.

The following packages are BROKEN:
  bzr bzrtools
The following packages have been automatically kept back:
  dhcp3-common texlive-generic-extra texlive-humanities texlive-humanities-doc
  texlive-latex-extra-doc texlive-pstricks texlive-pstricks-doc
The following packages have been kept back:
  dhcp3-client texlive-latex-extra
1 packages upgraded, 0 newly installed, 0 to remove and 10 not upgraded.
Need to get 2776kB of archives. After unpacking 217kB will be freed.
The following packages have unmet dependencies:
  bzrtools: Depends: bzr (< 1.4~) but 1.17-1~bazaar1~hardy1 is to be installed.
  bzr: Depends: python-central (>= 0.6.7) but 0.6.5ubuntu1 is installed.
Resolving dependencies...
The following actions will resolve these dependencies:

Remove the following packages:

Score is -10172

Accept this solution? [Y/n/q/?]


reply via email to

[Prev in Thread] Current Thread [Next in Thread]