[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gNewSense-users] HP Deskjet 2560

From: Sam Geeraerts
Subject: Re: [gNewSense-users] HP Deskjet 2560
Date: Wed, 05 Aug 2009 19:25:30 +0200
User-agent: Thunderbird (X11/20090711)

Brian Kemp schreef:

"I tried this printer on Ubuntu 8.04 Hardy Heron, and with the help of
hlplip, it works fine. I had to do a little extra work, because the standard
Ubuntu 8.04 had hplit 2.8.2 on board, which is not appropiate. You should
install 2.8.5 or higher. I tried the automatic installer, but that did not
work. Then I installed 2.8.7 manually, followed the instructions, and
everything works fine!"

gNS 2.2 is based on Ubuntu 8.04, which means that hpilp is going to be

You will need to install a later version of hpilp. Someone could set up
packages or a PPA maybe? I'd love to see a gNS PPA/backport repository. We
have one for icecat :)

Launchpad, including Soyuz (a.k.a. PPA's), is free now, so I'd say PPA's are not discouraged.

PLEASE NOTE: hpilp does include binary-only firmware for certain printers.
The d2560 does *NOT* require binary firmware--BUT if you use a vanilla hpilp
install you will probably end up with this firmware lying around on your
disk, being useless and taking up space and looking blobby.

Does HPLIP actually include the firmware? This might be a bug for gNewSense because we don't change the Ubuntu package and I'm not so sure that Ubuntu or even Debian remove anything from it.

A quick browse through HPLIP's Debian bugs shows that very likely something is not OK. It seems that HPLIP could download some non-free blobs [1]. I'll check into it later and open a bug report if nobody beats me to it.

A PPA/package repo for hpilp would fix this, because we'd just strip out the

Ideas about how we'd "just" strip out the firmware are welcome. :)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]