[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[gNewSense-users] fsfuzzer tool causes freeze on yeeloong with 2.6.32

From: Daniel Clark
Subject: [gNewSense-users] fsfuzzer tool causes freeze on yeeloong with 2.6.32
Date: Sun, 03 Jan 2010 21:25:59 -0500
User-agent: Thunderbird (X11/20090817)

Hi, just thought I'd point people at a tool that may be useful in
tracking down the cause of the periodic i/o bug mentioned at:

The fsfuzzer tool does stress tests of various filesystems in a
reproducible and logged way. For some reason it isn't working with ext2
or ext3 (I think it is just some sillyness with debian differing from
redhat in exact names of commands or something), but using the cramfs
tests it seems to cause a hard lockup on the yeeloong consistently
(using 2.6.32). I also tried running it on my x86_64 box running 2.6.28,
where it worked fine (ran to completion without causing any system

It is available from:

To compile you need to:
sudo aptitude install libattr1-dev

I'll be trying other things later, but thought this might be useful to
someone who knows how to debug the kernel, linux, as it seems to hit the
same bug as the rsync does but in a faster time and in a more
reproducible and easier to set up way.

Daniel JB Clark   | Sys Admin, Free Software Foundation |

reply via email to

[Prev in Thread] Current Thread [Next in Thread]