[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[gNewSense-users] Observations after reinstalling GNS on a Yeeloong lapt

From: samy boutayeb
Subject: [gNewSense-users] Observations after reinstalling GNS on a Yeeloong laptop
Date: Wed, 19 Jan 2011 07:56:26 +0100

>> 2/ The upgrade to the 2.6.37 kernel requires to change from hda to
sda in the /etc/fstab and in /boot/grub.cfg

> I noticed that too. I edited the wiki page accordingly a few days ago.


>> 3/ PMON graphical interface
>> The PMON graphical interface offers a more userfriendly way to change
the system parameters.

>> Open it by pressing the "b" key at boot time 

> Doesn't work on my machine. If someone can figure out the specifics of
this, please add to the Lemote page on our wiki.

>> However, some parameter changes are saved correctly whereas some
other not:

> Lemote is still actively developping PMON [1]. You could submit bug
reports about your problems.

I informed the PMON project owner.

>> 6/ With the 2.6.35 and the 2.6.37 kernels the yeelong-base and
grub-yeeloong packages seem to be not more required. However the suspend
to ram and the hibernate function dont work anymore.

> Yeeloong-base does 2 things (so far): update the kernel and provide an
init script for wifi. We've kept to 2.6.32 for a while now because there
was no real need to update.

> Yeeloong-base also pulls in grub-yeeloong because it's a nicer boot
loader than PMON. It's slow, but I hear that's a lot better in newer
versions of GRUB (should even be usable as a firmware replacement for
PMON). We haven't got around to updating it yet.


> Suspend and hibernate work for me with both .35 and .37. Make sure you
edit the swap partition in /etc/fstab for .37. Do you get any error
messages (check dmesg)?

After trying "suspend to ram", dmesg says:

ata& SRST failed (errno=-16

After tried to hibernate, the dmesg says:

PM: thaw of devices complete after 322.949 msecs
PM: Cannot find swap device, try swapon -a
PM: Cannot get swap writer

The swap line in /etc/fstab is

/dev/sda5 none swap sw 0 0

This said, I though that the issue was that the swap partition was
incorrectly set to 83 (instead of 82) in fdisk. I changed it and...

got the same output in dmesg

Same result after executing 

swapon -a

Anyway, it's good to know that the power management is working on you
configuration. I'll investigate further here later.

Kind regards

reply via email to

[Prev in Thread] Current Thread [Next in Thread]