[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gNewSense-users] Cant connect to internet / not wifi (thru LAN)

From: James L. Mazurek
Subject: Re: [gNewSense-users] Cant connect to internet / not wifi (thru LAN)
Date: Sun, 20 Mar 2016 17:08:23 -0500 (CDT)
User-agent: Alpine 2.02 (DEB 1266 2009-07-14)

On Sat, 19 Mar 2016, Xavi Drudis Ferran wrote:

El Fri, Mar 18, 2016 at 10:15:20PM +0100, Sam Geeraerts deia:
Op Fri, 18 Mar 2016 11:17:59 +0530
schreef "Tanzeem M.B" <address@hidden>:

> 00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller
> (rev 01) 03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
> RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)?

That should work with the r8169 driver. What's the output of

sudo modprobe r8169
sudo ifconfig -a

I don't know if I'm helping or just adding noise, but there's also a
realtek driver r8168, it seems. But someone from Realtek also commits
to's r8169, it seems, so I don't understand why there are
two drivers. Beware, if you follow these instructions (which I haven't tried)
I don't know if non-free firmware will be loaded or what, I haven't
checked. It seems the last supported kernel by r8168 is 3.10 ?

This seems riskier than what Sam says, so please first follow Sam's advise.


I ran into a similar issue the other week working with debootstrap generated installs of Debian 8 and Ubuntu 12.04. The issue being that the r8169 kernel module was being loaded but the non-free firmware was not.

The solution I found was to:

1. Make sure the required non-free firmware is installed correctly.
2. Backup and remove /etc/udev/rules.d/70-persistent-net.rules file.
3. Reboot the machine to permit udev to regenerate the rules file.

I suspect there may be a udev issue caused by not having the required firmware installed during the initial installation or in my case first boot. I'm not sure if the problem is limited to the r8169 driver.

I don't know if this will work for you but it may be worth a try.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]