[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gNewSense-users] cant connect to internet using cable lan

From: Tanzeem M.B
Subject: Re: [gNewSense-users] cant connect to internet using cable lan
Date: Tue, 22 Mar 2016 13:38:23 +0530

How do i check whether the required non-free-firmware is installed correctly.
Now i am not getting the message "non-free firmware not installed" on booting.
I set up the network configuration and IP as it was when i was using Debian in the same PC.
But I cant connect to internet. should i do any ifup command manually.

On 21 March 2016 at 21:31, <address@hidden> wrote:
Send gNewSense-users mailing list submissions to

To subscribe or unsubscribe via the World Wide Web, visit
or, via email, send a message with subject or body 'help' to

You can reach the person managing the list at

When replying, please edit your Subject line so it is more specific
than "Re: Contents of gNewSense-users digest..."

Today's Topics:

   1. Re: Cant connect to internet / not wifi (thru LAN)
      (James L. Mazurek)


Message: 1
Date: Sun, 20 Mar 2016 17:08:23 -0500 (CDT)
From: "James L. Mazurek" <address@hidden>
To: Xavi Drudis Ferran <address@hidden>
Cc: address@hidden
Subject: Re: [gNewSense-users] Cant connect to internet / not wifi
        (thru LAN)
Message-ID: <address@hidden>
Content-Type: TEXT/PLAIN; format=flowed; charset=US-ASCII

On Sat, 19 Mar 2016, Xavi Drudis Ferran wrote:

> El Fri, Mar 18, 2016 at 10:15:20PM +0100, Sam Geeraerts deia:
>> Op Fri, 18 Mar 2016 11:17:59 +0530
>> schreef "Tanzeem M.B" <address@hidden>:
>> > 00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller
>> > (rev 01) 03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
>> > RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)?
>> That should work with the r8169 driver. What's the output of
>> sudo modprobe r8169
>> sudo ifconfig -a
> I don't know if I'm helping or just adding noise, but there's also a
> realtek driver r8168, it seems. But someone from Realtek also commits
> to's r8169, it seems, so I don't understand why there are
> two drivers. Beware, if you follow these instructions (which I haven't tried)
> I don't know if non-free firmware will be loaded or what, I haven't
> checked. It seems the last supported kernel by r8168 is 3.10 ?
> This seems riskier than what Sam says, so please first follow Sam's advise.


I ran into a similar issue the other week working with debootstrap
generated installs of Debian 8 and Ubuntu 12.04. The issue being that the
r8169 kernel module was being loaded but the non-free firmware was not.

The solution I found was to:

1. Make sure the required non-free firmware is installed correctly.
2. Backup and remove /etc/udev/rules.d/70-persistent-net.rules file.
3. Reboot the machine to permit udev to regenerate the rules file.

I suspect there may be a udev issue caused by not having the required
firmware installed during the initial installation or in my case first
boot. I'm not sure if the problem is limited to the r8169 driver.

I don't know if this will work for you but it may be worth a try.


gNewSense-users mailing list

End of gNewSense-users Digest, Vol 106, Issue 10

reply via email to

[Prev in Thread] Current Thread [Next in Thread]