[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gNewSense-users] Recent Success with compile and 10 TB Volume Mount

From: Narcis Garcia
Subject: Re: [gNewSense-users] Recent Success with compile and 10 TB Volume Mount
Date: Wed, 17 Jul 2019 09:16:30 +0200

Here you have a recipe to remove metadata_csum :

Once this is done, older Linux kernels work with that filesystem.

El 17/7/19 a les 0:47, Will Hill ha escrit:
> I was recently able to compile a 4.2 kernel on 686 GNewsense and then use it 
> to mount a 10 TB encrypted USB drive with a newer ext4 file system.  This 
> makes it a little easier to share files between my computers at home and may 
> make other devices available to my GNewsense installs.  
> The notes I made for myself were:
> I'd like to have ext4 partitions made on Stretch work on my TV computer, 
> which 
> has a 32bit GNewsense install.  New Ext4_Metadata_Checksums features made 
> this difficult.  
> I followed my notes for mounting encrypted volumes here,
> but ran into a checksum difference.  GNewsense has a 3.2 kernel which does 
> not 
> seem to be able to read some ext4 attributes, so the device does not mount 
> rw.  I got,
> "EXT4-fs (dm-3): couldn't mount RDWR because of unsupported optional features 
> (400)"
> This seems to be due to a new metadata checksum,
> The recommended cure is to install a new kernel, 3.6 and above and a newer 
> version of e2fsprogs.  Unfortunately, I don't have an 686 kernel package 
> sitting around, so I'll use the TV install to compile one using the 
> instructions from Jessie - see pdf capture.  I just happen  to have 4.2 linux 
> libre kernel source, one of the last kernels that does not trigger the 
> Coreboot century bug in the versions of Libreboot I have.
> I got Gnewsense fakeroot and kernel-package ... and that fails.  falling back 
> to older instructions, which also call for build-essential and build-dep 
> linux
> The I used make config, long and tedious but make xconfig and make menuconfig 
> failed me.  
> make clean, worked
> make deb-pkg failed for lack of bc, apt-get install bc worked, seems to have 
> fixed that problem.
> ... and success one of the best compiles I've done yet.  
> willhill@gnewsense:~/src/librelinux$ ls -lrth
> total 39M
> -rw-r--r--  1 willhill willhill  62K Jun 29 13:48 
> debian-ch08s06-compiling_a_new_kernel.pdf
> drwxr-xr-x 25 willhill willhill 4.0K Jun 29 15:40 linux-4.2.5
> -rw-r--r--  1 willhill willhill 3.7K Jun 29 15:40 
> linux-firmware-image-4.2.5-gnu1_4.2.5-gnu1-1_i386.deb
> -rw-r--r--  1 willhill willhill 9.2M Jun 29 15:40 
> linux-headers-4.2.5-gnu1_4.2.5-gnu1-1_i386.deb
> -rw-r--r--  1 willhill willhill 1.1M Jun 29 15:40 
> linux-libc-dev_4.2.5-gnu1-1_i386.deb
> -rw-r--r--  1 willhill willhill  29M Jun 29 15:40 
> linux-image-4.2.5-gnu1_4.2.5-gnu1-1_i386.deb
> all packages installed without issue and archived for future use.  
> The new kernel booted.  After starting cryptsys again, I was able to mount 
> the 
> 10TB drive as dm-3 to /mnt.
> This method does not cleanly unmount devices, so it's only useful for drives 
> you want on till shutdown.  Gnome-disks in Debian Stretch does clean mounts 
> and unmounts, so I can sync things on other computers running that software 
> until I understand how it works.  I managed to install a newer version of 
> gnome-disks on Debian Wheezy through the Guix package manager, but it was 
> unable to mount or even see drive volumes.  
> This method might also completely blow up your files because, I don't think 
> that I installed newer versions of e2fsprogs.  I imagined that I might find 
> and install those through Debian backports, but I did not document it and two 
> months later don't remember if I did or not.  I'm not too worried about the 
> files on my TV computer blowing up.  
> Happy hacking.
> _______________________________________________
> gNewSense-users mailing list
> address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]