gnugo-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gnugo-devel] new version of escape patch posted


From: Arend Bayer
Subject: Re: [gnugo-devel] new version of escape patch posted
Date: Sat, 4 Sep 2004 00:09:05 +0200 (CEST)


Gunnar wrote:
> Arend wrote:
> > ...and linked on patches.html. I am now running this on KGS (TheGNUGo)
> > to get more a better impression.
> 
> How is the current breakage looking?

I am at 98 PASS and 76 FAILs; this is a net improvement of a little more
than 10 PASSes I think, but this should be taken with a grain of salt,
as I have heavily tuned the parameters against our regression tests. (On
the other hand, CVS has of course been tuned a lot against them, too, so
I am not sure what to make out of the results.)


> Some random comments to the patch:
> 
> > +/* Returns true if the empty vertex respectively the string at pos1 is
> > + * adjacent to the empty vertex respectively the string at pos2.
> > + */
> > +int are_neighbors(int pos1, int pos2)
> 
> I think you should break out auxiliary pieces like this from the patch
> and apply them right away.

Ok, will do where they look generally useful.

> >  #endif  /* _LIBERTY_H_ */
> >  
> > +float owl_escape;
> > +float escape_coeff;
> > +float escape_exp;
> > +float max_escape_route;
> > +float escape_default_attenuation;
> > +
> 
> I hope this is a temporary placement. It doesn't make sense to have
> them outside the #ifndef.

Oops right. Actually, I think I will kill completely kill these
variables and make them #define's; I don't think it is worth keeping
them adjustable via command-line parameters.

I used this to optimize them via an automatic script.

> > Index: engine/printutils.c
> > ===================================================================
> > [...]
> > +/* Adds square marks for each goal intersecion in the current sgf_dumptree.
> > + * This function cannot be in sgf/ as it has to understand the 1-D board.
> > + */
> > +void
> > +mark_goal_in_sgf(char goal[BOARDMAX])

> > +}
> 
> I think this function should go into engine/sgffile.c. Btw, isn't it
> already in CVS?

Ok. Yes I forgot to 'cvs update' before generating the diff.

> > -ladder_capturable(int pos, int color)
> > +ladder_capturable(int pos, int color, int result_to_beat)
> > [...]
> > -    if (liberties == 1 && attack(pos, NULL) == WIN)
> > +    if (liberties == 1 && attack(pos, NULL) >= result_to_beat)
> 
> I associate "beat" with strict inequality, i.e. that merely reaching
> the same result would not be good enough. Maybe some native speaker
> could comment and (if needed) suggest a better name for the parameter.
"result_to_get"?

Arend





reply via email to

[Prev in Thread] Current Thread [Next in Thread]