[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnumed-devel] bootstrap error on Mandriva 2010 - not really solved

From: Karsten Hilbert
Subject: Re: [Gnumed-devel] bootstrap error on Mandriva 2010 - not really solved
Date: Mon, 20 Sep 2010 10:26:57 +0200
User-agent: Mutt/1.5.20 (2009-06-14)

On Sun, Sep 19, 2010 at 08:43:43PM +0200, Michael Schütt wrote:

> > please send us the bootstrap-latest.log 
> here it is. But I'm not sure, if it is the right file.
> The logfile has date 25.07.2010

Your system clock is correct, I assume ?

How did you install the server files ?

        - package ?
        - tarball ?

How did you call the bootstrapper ?

        - gm-bootstrap_server ?
        - from inside a tarball ?

> and is located under /usr/lib/GNUmed-server/server/bootstrap,

That's likely the correct place for the log file when
bootstrapping from a package installed systemwide.

> where is nothinng else
> as this log file. All other under /usr/lib/GNUmed-server/ is empty.
> The install files are under /usr/lib/gnumed-server/
> (GNUmed-server <> gnumed-server)

Oh, perhaps the package failed to create


during install and the log file went missing because of that ?

Anyway. Here is the relevant code from the bootstrapper:

                env_var = 'GM_DB_PORT'
                self.port = os.getenv(env_var)
                if self.port is None:
              'environment variable [%s] is not set, using 
database port from config file' % env_var)
                        self.port = cfg_get(self.section, "port")
              'using database port [%s] from environment 
variable [%s]' % (self.port, env_var))
                if self.port is None:
                        _log.error("Need to know the database server port 
                        return None

which is duly reflected in the (likely old) log file:

> 2010-07-25 15:41:12  INFO      gm.bootstrapper 
> (./ #347): 
> using database port [5433] from environment variable [GM_DB_PORT]

So, ATM, I am not sure why it then gives an error message
about a socket at port 5432. One thing you might try is doing

        export PGPORT="5432"

in addition to setting GM_DB_PORT such that this will
configure any libpq-based software we might have missed to
pass "-p GM_DB_PORT" to. I added this to the relevant shell
scripts now.

GPG key ID E4071346 @
E167 67FD A291 2BEA 73BD  4537 78B9 A9F9 E407 1346

reply via email to

[Prev in Thread] Current Thread [Next in Thread]