[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnump3d-users] Root on another partition

From: Paulo Moura Guedes
Subject: Re: [Gnump3d-users] Root on another partition
Date: Thu, 15 Nov 2007 11:35:51 +0000
User-agent: KMail/1.9.6 (enterprise 0.20070907.709405)

On Thursday 15 November 2007 00:01:31 you wrote:
> On Wed Nov 14, 2007 at 23:52:08 +0000, Paulo Moura Guedes wrote:
> > > > However, with /mnt/data as root dir, I can only make it work with
> > > > user = root.
> > >
> > >   Yes, since user 'gnump3d' doesn't have permission to read that
> > >  directory.
> >
> > I tried with my user ("mourao") which, as I said, belongs to plugdev.
>   By default gnump3d runs with user=gnump3d.  If you say that you've
>  changed that to 'user=maurao' and that fails then I'm going to guess
>  that it is an issue of the *primary group* of the user which is
>  causing problems.


>   From memory the code, when started by root, tries to change to
>  the primary group of the user - then the actual user.  So if the
>  primary group of 'gnump3d' is 'gnump3d', or something else, then
>  this will fail.
>   Simplest suggestion is to change the primary group.

OK, the problem was that plugdev was a secondary group of mourao. Apparently 
it only works if it is a primary group (don't know why).

I put back user = gnump3d instead of mourao, changed the primary group of 
gnupm3d to plugdev and it worked!

Thanks a lot

reply via email to

[Prev in Thread] Current Thread [Next in Thread]