[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [GNUnet-developers] debian packages of 0.5.4

From: Uli Luckas
Subject: Re: [GNUnet-developers] debian packages of 0.5.4
Date: Tue, 8 Jul 2003 13:47:17 +0200

Christian Grothoff wrote:
> Hash: SHA1
> On Wednesday 25 June 2003 07:50 am, Uli Luckas wrote:
>> Am Dienstag, 27. Mai 2003 22:18 schrieb Glenn McGrath:
>>> I have some debian packages available of 0.5.4 at
>> I just installed the debian packages and can't get them to work
>> properly.
>> 1) "gnunet-search GPL" does not find anything
> Have you tried "test" or "gpl"?
>> 2) "gnunet-insert-multi foo-bar.mp3" complains:
>> Loading library libextractor_pdf failed
>> (/usr/lib/ undefined symbol:
>> __gxx_personality_v0)!
> That will be fixed in the next version of libextractor (I hope).
> Should not affect anything but pdf file insertions.
>> Jun 25 14:48:21 FAILURE: symcipher.c:encryptBlock: gcry_cipher_setkey
>> failed (weak encryption key)!
>> Jun 25 14:48:21 FATAL: encryption failed!?Jun 25 14:48:21 __BREAK__
>> at logging.c:226
>> Does any one know where the "weak encryption key" message comes
>> form? And, of course, what to do about it?
> It means, that the key chosen for the encryption was classified by
> libgcrypt as "weak" (that is, easier to break than it should be).
> Typically, there is some bit-pattern in the key (e.g. all-zeros would
> probably do it) that makes the key not work properly.  Now, for
> insertion, you don't get to pick or generate keys, they are derived
> from the hash-code. Now, it seems that for your particular file,
> either the contents or the keywords hash to a key that happens to be
> classified as "weak". It is definitely something that should hardly
> ever occur. Could you try building GNUnet with OpenSSL or the new,
> build-in crypto code and see if the error happens with those crypto
> systems, too?
> Either way, it might be good if you could file a report on Mantis
> (with the file in question attached) such that I can try to reproduce
> this.
Hi Christian,
the "encryption failed" problem did not depend on the file to be inserted.
The error was always produced. I think it was a debian-package specific
problem, as an update to Glenn McGrath's lates packages solved the
insert-problem. Maybe Glen can shed some light on what he changed.
The other problem is still there: I still can't find anything in gnunet -
not even "gpl" "GPL" or stuff I inserted myself. But I don't have the time
to track the problem down right now. may be later.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]