[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[GNUnet-developers] libextractor, macos x

From: Jussi Eloranta
Subject: [GNUnet-developers] libextractor, macos x
Date: Sun, 14 Mar 2004 18:56:34 +0200


Couple of things I ran into with gnunet 0.6.1c:


On GNU/Linux (Fedora) I get:

Resolving symbol 'libextractor_lower_extract' in library libextractor_lower failed, so I tried '_libextractor_lower_extract', but that failed also. Errors are: /usr/lib/ undefined symbol: libextractor_lower_extract; and then: /usr/lib/ undefined symbol: _libextractor_lower_extract Inserting test.dat (no description supplied, unknown) under keyword test.dat.

My guess is that the function name in libextractor (0.2.6) file
.../plugins/lowerextractor.c has wrong function name:

extract() should be libextractor_lower_extract() ? Or was this generated somehow automagically and this just did something

2. On MacOS X (10.3.2 with gcc-3.3 from apple) the existing config stuf for extractor 0.2.6 did not
work for me. I had to modify the file as follows:

case "$host_os" in
# AC_DEFINE([USE_NS_MODULE],1,[Determines if we should use the NSModule API for dynamic loading])

[This requires libtool stuff installed under /sw, which is the default if one is using Fink] Also maybe one should add a switch to configure which would allow
specification of libltdtl?

3. dictionary-builder.c in ... plugins/printable

dumps core. This seems to be due to the following line (isol. within !!!s):

  while (1 == fscanf(dictin, "%s", (char*)&line)) {
    words[cnt] = strdup(line);

    if (words[cnt][strlen(words[cnt]-1)] != '%')


There were no % characters in the *.txt files so I just commented
the above line. Is the idea that % is a comment sign ?

BTW configure sets up the compilation for gcc-3.3 (from Apple).

4. On MacOS X there is no values.h header (which is btw obsolete anyway)

I believe that this should be replaced with limits.h and float.h
and correct symbols should be used? (well, it compiles with these two)

This reference occurs in GNUnet-0.6.1c/src/applications/afs/module/manager.c

I used the following configure line:

/configure --with-extractor=/usr/local --with-gdbm=/sw

(gdbm was installed from Fink) Also I believe that the compilation found libltdl from /sw (FInk again).

5. Weird dynamic linker problem on Macos X. It insisted that _gettext
could not be found when I start gnunetd. If force it to look for libintl.dylib
then it works, ie.:

setenv DYLD_INSERT_LIBRARIES /sw/lib/libintl.dylib

It appears to be a problem for all gnunet-* binaries (so a quick hack
is to put the setenv in .cshrc or whateverRC).

This is probably a problem on my machine... but who knows...

6. Files download correctly but at the end of download (and occasionally during download) I get:

[comp56:~/gnunet-downloads] % gnunet-gtk
Mar 7 21:52:18 FAILURE: file corrupted (or bug), top crc mismatch in block 1 0: 7d9f6b4d != 25812b15 or 466dc92 != 466dc92
Mar  7 21:52:18 __BREAK__ at block.c:1825
Mar  7 21:52:18 top CRC mismatch!
Mar  7 21:52:18 __BREAK__ at logging.c:240

It calims CRC error but, in fact, there is no error in the downloaded



reply via email to

[Prev in Thread] Current Thread [Next in Thread]