[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [GNUnet-developers] GNUnet 0.6.3a released

From: Christian Grothoff
Subject: Re: [GNUnet-developers] GNUnet 0.6.3a released
Date: Fri, 6 Aug 2004 17:06:54 +0530
User-agent: KMail/1.5

On Friday 06 Aug 2004 4:03 pm, Glenn McGrath wrote:
> On Fri, 6 Aug 2004 13:06:05 +0530
> Christian Grothoff <address@hidden> wrote:
> > I just recalled something in this context.  Plese try compiling with
> > -O0 (no optimizations, export CFLAGS="-O0".  I believe I encounted
> > some gcc bug when I worked on this code and the only way to fix it was
> > to disable optimizations. - C
> Yea, that does the trick for me, i only get one test failure now.

The question now is, should we force -O0 in configure, warn for -O2 or just 
have people compile GNUnet and blame it on our code if their gcc is buggy 
(with -O2 the return of a 'strdup' operation on a valid string is garbage, at 
least according to gdb and the crash that happens).  I don't see how we could 
do a decend workaround in the code.  Then again it feels wrong to force 
compiler options on people.  Any opinions?  Other experiences?  

> Aug  6 20:27:21  Unable to open /home/bug1/.my.cnf
> Aug  6 20:27:21 __BREAK__ at logging.c:297
> /bin/sh: line 1: 22235 Aborted                 ${dir}$tst
> FAIL: high_db_test_mysql
> Maybe i dont have mysql setup properly for that test, dotn know much
> about it.

Yes, I get that error, too.  The reason is that mysql is not properly 
configured on your system (~/.my.conf should contain the login information 
for the database).  0.6.3 now tests all databases for which the modules were 
built, not just the one that is configured in gnunet.conf.  That's why these 
tests 'suddenly' fail: they are new.

> Also, the file gnunet-download.scm isnt included in the tarball, which
> breaks builds unless the --without-guile option is used, i should be
> able to make a patch quick patch to fix this.

Ah! The .scm file was not in EXTRA_DIST but the bin_SCRIPTS target was 
conditional.  Which worked as long as I was building the distribution on a 
machine where Guile was found.  Fixed in CVS now.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]