[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


From: guilherme
Subject: Hi!
Date: Sun, 13 Jun 2021 23:35:34 +0200 (CEST)


I'm new to the list, so I'll introduce myself first. My name is Guilherme Macedo and I live in Munich. I found about GNUnet and re:claimID after getting interested in descentralized identity, verifiable credentials and SIOP. I think that there is too much centralization and lack of control and privacy in the present Internet.

After watching the presentation about DISSENS at Open Identity Summit, I got in contact with Martin Schanzenbach, because the main idea behind GNUnet is really amazing. I would like to somehow contribute to the project, but it has been a while since I last programmed in C and had to deal with missing headers :)

I was experimenting with and, but unfortunately I'm unable to compile it. So I would like to ask a few questions, if possible please.

1. seems a bit abandoned (last commit was in Jan 2020). Is there a more up to date version being maintained by GNUnet developers?

2. Was anyone able to compile it?

3. I'm trying to compile it on an Ubuntu Docker image, but my build always fail. The best clue that I've is that it can't find some headers and files while compiling emscripten-fastcomp v1.39.6. I tried hard to find them and install, but I really can't find those missing files. Might be a super beginner mistake.

# grep "not found" tmp/build-utils/emscripten-fastcomp/log/compile.log
-- Looking for malloc/malloc.h - not found
-- Looking for ndir.h - not found
-- Looking for sys/ndir.h - not found
-- Looking for valgrind/valgrind.h - not found
-- Looking for mach/mach.h - not found
-- Looking for histedit.h - not found
-- Looking for CrashReporterClient.h - not found
-- Looking for pthread_create in pthreads - not found
-- Looking for xar_open in xar - not found
-- Looking for arc4random - not found
-- Looking for mallctl - not found
-- Looking for malloc_zone_statistics - not found
-- Looking for strerror_s - not found
-- Looking for dladdr - not found

Has anyone experienced the same error?

I'm new to emscripten, so now I'm trying to find a way to make the gnunet-web build directly reference the binaries from emscripten, instead of compiling everything from source.

Any help is appreciated.

Thank you for all the effort in maintaining such amazing project.

Best regards and have a nice week!

Guilherme Macedo

reply via email to

[Prev in Thread] Current Thread [Next in Thread]