[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Compiling in OpenBSD: cannot find libsodium

From: Schanzenbach, Martin
Subject: Re: Compiling in OpenBSD: cannot find libsodium
Date: Sat, 26 Jun 2021 08:45:52 +0000

Hi anoduck,

I think we did not include --with-sodium switches.
Can you try setting
$ export CFLAGS="$CFLAGS -I/usr/local/include"


$ export LDFLAGS="$LDFLAGS -L/usr/local/lib"
$ ./configure --prefix=...

to see if that at least fixes your build?


> On 26. Jun 2021, at 04:25, anoduck <> wrote:
> During the `/configure --prefix=$GNUNET_PREFIX/..` command, configure cannot 
> not locate libsodium. Libsodium is located in 
> `/usr/local/lib/` which is the same as the gnunet prefix. I 
> tried using `--with-libsodium=/usr/local/lib` which didn't work, then I tried 
> using the `--ldflags` which didn't work, and I also tried using `-L` that 
> didn't work. I cannot remember how I should reference the location of the 
> sodium library to successfully achieve setup for compilation.
> Thanks,
> anoduck
> Sent with ProtonMail Secure Email.

Attachment: signature.asc
Description: Message signed with OpenPGP

reply via email to

[Prev in Thread] Current Thread [Next in Thread]