[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Not able to run recent versions

From: t3sserakt
Subject: Re: Not able to run recent versions
Date: Tue, 5 Dec 2023 17:26:03 +0000

On 05.12.23 17:50, bitestring--- via Mailinglist for GNUnet developers wrote:
Hi GNUnet developers,

Hope you are doing good. I have been playing with GNUnet for a while. Recently, I am facing two issues with newer GNUnet versions (0.20.0 I guess)

1. I am not able to run it successfully on my Fedora Linux machine. If I run gnunet-arm -s, it starts all services but gnunet-search command does not work at all.  I have attached logs with this email. Could you please help identify what is wrong?
By looking in the log file I guess you are running code which is newer than 0.20. Head from master does not work with peers running 0.20.

2. gnunet-peerinfo CLI and APIs are missing. I tried to create a Rust program by generating C bindings but  peerinfo headers and libraries are missing in git master. This service used to be in previous versions. If it is removed, how can I list all peers my machine is connected to?

We have carried out an extensive redesign of the transport subsystem, changed the format of the hello messages (address information of peers), and the hello data is not stored in peerinfo anymore. This functionality was moved to peerstore, but we do not yet have a replacement for the gnunet-peerinfo cmd. 

By the way. gnunet-peerinfo does not give you connections, but address information of peers.

gnunet-core gives you information about connections with direct neighbours (not necessarily peers with whom you communicate, but those you relaying messages for). gnunet-cadet gives you information about peers you like to communicate with.

Happy hacking!


Attachment: OpenPGP_0x524982A0100F7490.asc
Description: OpenPGP public key

Attachment: OpenPGP_signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]