[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GNUstep on Win32

From: Richard Frith-Macdonald
Subject: Re: GNUstep on Win32
Date: Sun, 9 Mar 2003 05:54:23 +0000

On Sunday, March 9, 2003, at 01:16  am, Fred Kiefer wrote:

I tried onece more to use GNUstep on MinGW (again on top of Cygwin). I
did get a lot further than the last time, but again failed. The first
problem I did encounter was the latest change Richard did on base. the
class FastMallocBuffer has been removed, but the symbol is still
exported by, compilation fails until this line
gets removed. I am not sure at which cvs branch this problem should be fixed.

Try using the branch for the 1.6.0 release... that's where i've been putting
all the bugfixes for windows and doing all the windows testing.

I could not work around the next problem that easily. After compiling
the rest of GNUstep, starting failed with a message from gdnc
complaining that it is "unable to get status of descriptor", but the
error message is that the operation was successful. This leaves me
puzzled and I don't have the slightest idea what the computer tries to
tell me. As I never before tried to use GSFileHandle on Windows I am not
sure if this is a new problem or even caused by my old environment that
is still in place.

It's attempting to determine whether a file descriptor is a standard file
or a socket.  As I haven't found out how to do that under windows yet,
the code just assumes it's a socket (gets distributed objects working)
but this really *is* something that needs looking into.
Really we need reliable ways to tell what sort of handle we have, and
for the NSRunLoop to act accordingly ... putting anything other than
a socket into a runloop is likely to fail.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]