[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GNUstep on Cygwin

From: Fred Kiefer
Subject: Re: GNUstep on Cygwin
Date: Mon, 08 Dec 2003 21:34:20 +0100
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030821

Adam Fedor wrote:
On Sunday, December 7, 2003, at 10:06 AM, Fred Kiefer wrote:
Now I have problems with the path conversion. GNUstep make did set my GNUstep system directory to c:/GNUstep/System. And now applications are looking for the backend bundle in a directory below this.

Did you try --with-prefix=/usr/GNUstep

since Cygwin should work with that? Just wondering...

It does work with this. For me it was also sufficent to replace the entries in with the /cygdrive/c/... notation and then things worked fine. Still I think as Cygwin now supports c:\... as well, we need to support this in base also.

In the meantime I also did give the GNUstep MinGW installer a try and this works nicely for base, but has none of the libraries for gui and back included. So I tried to download libtiff, libjpeg and so on. I used the libtiff from he offical MinGW repository and this still does not work. As I don't have access to my mail from my window environment I needed to boot Linux again to find out which one to use. My impression here is that a Cygwin based installation is still easier. If we would offer an objc.dll to download all the external componentes would be available via the standard Cygwin installation.

But as the Cygwin environment is now soemwhat working I will try to use this. One of the remaining problems is that the connection to the gdnc cannot be found. Could anybody please look into this? One workaround for this has been suggested some time ago: We could add a switch to not try this connection. If CVS ever gets back I will add a patch for this.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]