[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

su, FFCall & crash

From: Manuel Guesdon
Subject: su, FFCall & crash
Date: Sun, 15 Apr 2007 17:35:52 +0200 (CEST)


Here is a crazy problem.
The system is a Mandrake2007 on a bi-xeon dual-core.
ffcall 1.10 rpm package is installed

I run the following attached test (FFCall/test00.m)

It works (there's an exception but this not the point) when I run it under 
valgrind. It also works when I ssh (same user) on the box or when I login 
directly on the box.

It dosn't works when I do a su (or a su --login), from root or even by directly 
logging under the user and doing a su user

I've put exactly the same environment for ssh test and su test and this doesn"t 

It crash when calling the ff_callback (see GSFFCallInvocation.m) for __VAuint 

I've attached 2 traces and ff_callback dissasembled code.

Any idea ?

Thank you !!


Manuel Guesdon - OXYMIUM <address@hidden>
14 rue Jean-Baptiste Clement  -  93200 Saint-Denis  -  France
Standard: 0 811 093 286 (Cout d'un appel local)   Fax: +33 1 7473 3971
LD Support: +33 1 7473 3973                       LD:  +33 1 7473 3980

Attachment: test.tgz
Description: GNU Zip compressed data

Attachment: dontworks.trace
Description: Binary data

Attachment: works.trace
Description: Binary data

Attachment: dontworks.asm
Description: Binary data

Attachment: works.asm
Description: Binary data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]