[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Compile issues

From: Jackie Gleason
Subject: Re: Compile issues
Date: Wed, 7 Dec 2011 21:28:23 -0500

I have tracked the problems down to this area of the make file....

if test "x$ac_cv_lib_pthread_pthread_join" = x""yes; then
  # Change this...

if I set pthread_ok=yes to goes on to the next issue (seems test are ran even when cross compile which of course fails.) 

Although that I can just change it I am worried I have my linking set up wrong, any help would be great.


2011/12/7 Jackie Gleason <address@hidden>
Oops forgot to include others...

---------- Forwarded message ----------
From: Jackie Gleason <address@hidden>
Date: Wed, Dec 7, 2011 at 9:47 AM
Subject: Re: Compile issues
To: Ivan Vučica <address@hidden>

Yup that looks like the right one. Looks like there is a link to the Labs toward the end. I am also looking into some of the options for a port of UIKit but not really getting anywhere. Some people have also been having success with Cocotron (using my toolchain compiling), however, since I don't have XCode or a mac (nor want one, although if I get desperate my gf does) I have stuck with trying to get GNUStep to compile (see original message).

I have included the config.log, however, I think the real problem here is for some reason the pthreads stuff isn't get included. This seems odd considering it should be included inside the platform folder. I know there can be some problems with Bionic and pthreads but join shouldn't be that issue. 

GnuStep Make seems to compile fine...

address@hidden:~/tmp/gnustep/make$ ls 
bin  etc  share
address@hidden:~/tmp/gnustep/make$ ls ./bin/
debugapp  gnustep-config  gnustep-tests  openapp  opentool

Am I missing some sort of fancy include in my CFLAGS or LDFLAGS?


On Wed, Dec 7, 2011 at 6:01 AM, Ivan Vučica <address@hidden> wrote:

For other interested parties, here is the link I dug out. Jackie, thanks for writing this, it looks great:
I'll link to the presentation from a smallish article I wrote on the same subject:

On Wed, Dec 7, 2011 at 02:25, Jackie Gleason <address@hidden> wrote:

I just happen to have created labs and a presentation I can share later or search twitter for @m3conf. The config.log didn't give any info but I will mail it when I get home.


On Dec 6, 2011 8:08 PM, "Ivan Vučica" <address@hidden> wrote:
First I'd like to ask you if you could post some instructions on building your own tool chain for Android :)

Next, please examine "config.log". It should among other things contain a full copy of the failed feature testing program's source code, as well as a more specific failure reason,

Can you send your "config.log" to the list?

If you manage to get Foundation to run on Android, please tell us more about it. I got some Objective-C code running on Android, but never tried compiling GS. I'd be very interested in hearing more about your experiences.

4. 12. 2011., u 18:16, Jackie Gleason <address@hidden> napisao:

First of all I am relatively new to C so some of the things I say maybe duh mistakes.

I am trying to compile GNUStep using a custom Toolchain I built for Android. I am just looking to make the shared libraries and headers I need to allow for use of Foundation. So I go into the base directory under the base directory I run the following....

./configure --prefix=/home/jackie/tmp/gnustep/base --host=armeb CC="/home/jackie/Development/Google/AndroidNDK/android-ndk-r6b/toolchains/arm-linux-androideabi-4.6.1/prebuilt/linux-x86_64/bin/arm-linux-androideabi-gcc" CPP_FLAGS="-I/home/jackie/Development/Google/AndroidNDK/android-ndk-r6b/platforms/android-8/arch-arm/usr/include/" CFLAGS="-nostdlib -I/home/jackie/Development/Google/AndroidNDK/android-ndk-r6b/platforms/android-8/arch-arm/usr/include/" LDFLAGS="-Wl,-rpath-link=/home/jackie/Development/Google/AndroidNDK/android-ndk-r6b/platforms/android-8/arch-arm/usr/lib -L/home/jackie/Development/Google/AndroidNDK/android-ndk-r6b/platforms/android-8/arch-arm/usr/lib" LIBS="-lc"

I get the following issue...

checking for pthread_join in -lpthread... no
configure: error: Unable to find pthread library (needed for thread support).

I know some pthread stuff doesn't work on Bionic but I thought that join shouldn't be an issue per...

Anyone able to help me with what I am doing wrong? Am I linking something wrong? If I go into make folder and run configure from there it works but only generates the executables.

Gnustep-dev mailing list

Ivan Vučica - address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]