[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Can't drag&drop menu in Gorm

From: Fred Kiefer
Subject: Re: Can't drag&drop menu in Gorm
Date: Sat, 28 Dec 2013 16:19:12 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Thunderbird/24.2.0

On 28.12.2013 15:28, Gregory Casamento wrote:
> Fred,
> On Sat, Dec 28, 2013 at 8:33 AM, Fred Kiefer <address@hidden> wrote:
>> On 28.12.2013 14:17, Gregory Casamento wrote:
>>> I really need to learn to stop using my phone dictation to send emails.
>> But it was fun to read :-)
> LOL, they often are. ;)
>>> I did a clean build of core, then a clean build of GORM. I then created a
>>> new empty document, then I went to the pallete and dragged a menu into
>> it.
>>> I did this on both platforms precisely the same and it worked for me
>> please
>>> let me know if I'm missing something.
>> Yes, that is what needs to be tested. In the meantime I tried with my
>> Windows virtual machine and there it works. Looks like German and I have
>> a local problem we need to solve ourselves. Still it would help if you
>> could point me to the class that should be accepting the drag of the
>> menu. Is it GormObjectEditor?
> Yes, that is one of the places you need to look.  Also look at
> GormPalettesManager.  There is code there which specifically handles
> dragging of menus and windows in the method draggedImage:endedAt:deposited:
> near line 105.

Thank you that seems to be the drag source. I also found the drag
destination it is the class GormDocumentWindow.

> Are you both using Ubuntu?  Perhaps I could help further by using a VM that
> runs Ubuntu instead of debian.

No I am using OpenSuse with a KDE window system. One of the problems
here seems to be that the D&D code always finds a window added by the
kwin window manager. That in itself might be the whole issue. But I am
wondering why this only happens for the menu, not for the window.
Dragging any sort of window works as expected. On the other hand
dragging a menu fails all the time.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]