[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GUI apps on windows do not startup anymore

From: Fred Kiefer
Subject: Re: GUI apps on windows do not startup anymore
Date: Mon, 27 Jan 2014 22:52:34 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Thunderbird/24.2.0

I just tried to run a newly updated and compiled GNUstep and Ink on
Windows and worked as usual. I did not change my MinGW installation though.

Could it be that you have some

On 27.01.2014 11:47, Riccardo Mottola wrote:
> I updated my core installation on windows. Now no application seems to
> start up anymore. I use win32-winlib
> If I try to start e.g. Ink, it will churn for a bit and drop to shell
> prompt again, without any window appearing. IN the event viewer I only
> see these entries:
> 2014-01-27 11:41:12.953 Ink[1280] screen 0:hdc: 65539 frame:top:0
> left:1920 right:3360 bottom:900  frame:x:1920.000000 y:0.000000
> w:1440.000000 h:900.000000
> 2014-01-27 11:41:12.990 Ink[1280] screen 1:hdc: 65537 frame:top:0 left:0
> right:1920 bottom:1080  frame:x:0.000000 y:0.000000 w:1920.000000
> h:1080.000000

This is some debug logging code that somebody left in
LoadDisplayMonitorInfo(), just ignore it.

> 2014-01-27 11:41:13.215 Ink[1280] CreateWindowEx Failed 0
> 2014-01-27 11:41:13.320 Ink[1280] CreateWindowEx Failed 0

This tells you that your window could not be created and that we have no
further information on why not. :-(

> It is interesting that they are double. Any clue what could be
> happening? i have never seen such errors.

Of course GNUstep creates multiple windows and at least tow of them fail.

Sorry for being of no help here,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]