gpsd-dev
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[gpsd-dev] [PATCH] Rename compiled_gpsdlib to static_gpsdlib since it's


From: Rob Norris
Subject: [gpsd-dev] [PATCH] Rename compiled_gpsdlib to static_gpsdlib since it's always statically built.
Date: Thu, 17 Mar 2016 20:52:42 +0000

Then remove it from the list of built libraries since when building any program 
that requires it, it is automatically included.

TESTED:
scons build-all check
and various individual programs such as (and a full clean between each run):
scons gpsctl
scons test_libgps
---
 SConstruct | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/SConstruct b/SConstruct
index 719d262..b304961 100644
--- a/SConstruct
+++ b/SConstruct
@@ -990,11 +990,11 @@ static_gpslib = env.StaticLibrary("gps_static",
                                   [env.StaticObject(s) for s in 
libgps_sources],
                                   rtlibs)
 
-compiled_gpsdlib = env.StaticLibrary(target="gpsd",
+static_gpsdlib = env.StaticLibrary(target="gpsd",
                            source=[env.StaticObject(s, parse_flags=usbflags + 
bluezflags) for s in libgpsd_sources],
                            parse_flags=usbflags + bluezflags)
 
-libraries = [compiled_gpslib, compiled_gpsdlib]
+libraries = [compiled_gpslib]
 
 # Only attempt to create the qt library if we have shared turned on otherwise 
we have a mismash of objects in library
 if qt_env:
-- 
2.7.0




reply via email to

[Prev in Thread] Current Thread [Next in Thread]