gpsd-dev
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: ✘gpsd 3.23.1 is released!


From: Miroslav Lichvar
Subject: Re: ✘gpsd 3.23.1 is released!
Date: Wed, 22 Sep 2021 09:29:55 +0200

On Tue, Sep 21, 2021 at 03:15:03PM -0700, Gary E. Miller wrote:
> gpsd 3.23.1 is released.  No ABI or API changes.  Random bug fixes
> from 3.23.

Thanks for the new release.

>   Change STATUS_NO_FIX to STATUS_UNK to avoid confusion with fix mode.
>   Change STATUS_FIX to STATUS_GPS to avoid confusion with fix mode.
>   Change STATUS_DGPS_FIX to STATUS_DGPS to avoid confusion with fix mode.

I think changing names of constants in a public header counts as an
API break. Existing software no longer builds.

I'd suggest to add the old names for compatibility, maybe like this?

--- a/include/gps.h
+++ b/include/gps.h
@@ -173,6 +173,11 @@ struct gps_fix_t {
  * PPS is the encrypted military P(Y)-code */
 #define STATUS_PPS_FIX  9
 
+// Old status names for compatibility
+#define STATUS_NO_FIX   STATUS_UNK
+#define STATUS_FIX      STATUS_GPS
+#define STATUS_DGPS_FIX STATUS_DGPS
+
     double ept;         /* Expected time uncertainty, seconds */
     double latitude;    /* Latitude in degrees (valid if mode >= 2) */
     double epy;         /* Latitude position uncertainty, meters */

-- 
Miroslav Lichvar




reply via email to

[Prev in Thread] Current Thread [Next in Thread]