[Top][All Lists]
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: user messages
From: |
Carles Pina i Estany |
Subject: |
Re: user messages |
Date: |
Sat, 26 Dec 2009 18:44:06 +0100 |
User-agent: |
Mutt/1.5.20 (2009-06-14) |
Hi,
On Dec/26/2009, Robert Millan wrote:
> On Sat, Dec 26, 2009 at 11:20:27AM +0100, Carles Pina i Estany wrote:
> > cmd_linux = grub_register_command ("linux", grub_cmd_linux,
> > - 0, "Load linux.");
> > + 0, "Load a Linux kernel.");
>
> The construct "Linux kernel" is very ambigous because it's not clear if
> it means "the kernel known as Linux" or "the kernel of Linux". Some
> people missinterpret it as "the kernel of Linux", leading to the
> long-standing confusion you probably heard about (but I'll paste
> a link anyway, for the sake of everyone else ;-)):
>
> http://www.gnu.org/gnu/linux-and-gnu.html
yeap I heard.
When I was writig that I was thinking it. I was interpreting as: "From
the available kernels, load a Linux one.". Like having multiple kernels
and loading a Linux one.
Never mind, it's ambigous.
> But I agree it should be capitalized. Please make that "Load Linux.".
done (see attached patch).
> For consistency, these could read "Load XNU.". If that's too confusing,
> maybe "Load XNU (kernel of Darwin)" or something like that. Vladimir what
> do you think?
I send attached a new patch. Let me to comment here the relevant
changes against the previous patch:
=== modified file 'loader/i386/bsd.c'
--- loader/i386/bsd.c 2009-12-26 10:01:33 +0000
+++ loader/i386/bsd.c 2009-12-26 17:38:12 +0000
@@ -1280,15 +1280,15 @@ GRUB_MOD_INIT (bsd)
{
cmd_freebsd = grub_register_extcmd ("kfreebsd", grub_cmd_freebsd,
GRUB_COMMAND_FLAG_BOTH,
- "FILE", "Load kernel of FreeBSD.",
+ "FILE", "Load FreeBSD kernel.",
freebsd_opts);
cmd_openbsd = grub_register_extcmd ("kopenbsd", grub_cmd_openbsd,
GRUB_COMMAND_FLAG_BOTH,
- "FILE", "Load kernel of OpenBSD.",
+ "FILE", "Load OpenBSD kernel.",
openbsd_opts);
cmd_netbsd = grub_register_extcmd ("knetbsd", grub_cmd_netbsd,
GRUB_COMMAND_FLAG_BOTH,
- "FILE", "Load kernel of NetBSD.",
+ "FILE", "Load NetBSD kernel.",
netbsd_opts);
how it sounds? maybe easier to read (if correct) "Load NetBSD kernel."
than other way?
XNU now is:
cmd_kernel = grub_register_command ("xnu_kernel", grub_cmd_xnu_kernel, 0,
- "Load a xnu kernel.");
+ "Load XNU.");
cmd_kernel64 = grub_register_command ("xnu_kernel64", grub_cmd_xnu_kernel64,
- 0, "Load a 64-bit xnu kernel.");
+ 0, "Load 64-bit XNU.");
cmd_mkext = grub_register_command ("xnu_mkext", grub_cmd_xnu_mkext, 0,
"Load XNU extension package.");
cmd_kext = grub_register_command ("xnu_kext", grub_cmd_xnu_kext, 0,
Vladimir, would you change something?
Thanks,
--
Carles Pina i Estany
http://pinux.info
messages02.patch
Description: Text Data