[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [h5md-user] Update on H5MD from Stuttgart

From: Pierre de Buyl
Subject: Re: [h5md-user] Update on H5MD from Stuttgart
Date: Wed, 17 Jul 2013 21:25:45 +0200
User-agent: Mutt/1.5.21 (2010-09-15)

On Wed, Jul 17, 2013 at 11:30:54AM -0400, Peter Colberg wrote:
> On Wed, Jul 17, 2013 at 02:28:28PM +0200, Pierre de Buyl wrote:
> > Following a discussion we had this morning with Felix, Olaf and Jonas, 
> > here's
> > what's been discussed and what is proposed.
> Pierre, thanks for the heads-up on the meeting!

My pleasure :-)

> > 1. Simple
> > 
> > An "id" dataset seemed necessary. It was discussed on the list and met no
> > opposition at the time. "id" is favoured over "tag" to underline its "unique
> > identifier" status.
> The type of a particle id is not mentioned in the text.

It is as of the commits I pushed in the (european) afternoon.

> I suppose the particle id is of integer type?

I omitted to put that explicitly, it is now present. The commit email should
arrive close to this one.

> > Within the box description, the nature of the boundaries of the box were 
> > still
> > missing, although discussed on the list. "type" is to be replaced by 
> > "geometry"
> > and "boundary" is to be added, with the value "open" or "periodic" in each
> > dimension.
> What is the value of “boundary” in the presence of walls?
> Note the definition of a closed system in thermodynamics: The system
> is closed with regard to flow of mass, but open with regard to flow
> of work and heat. Maybe it should be made explicit that “closed” and
> “open” only refers to the flow of mass through the boundaries.

"open" was chosen to specify "non-periodic". Indeed, a lot of the discussion of
this morning was about avoiding confusion and ambiguities. A solution would be
to have
- "open": no wall and no pbc
- "closed": walls, not specifying (yet) what kind of wall it is.
- "periodic": periodic

> > 2. Less simple
> > 
> > 2.1 "/trajectory"
> > 
> > One change seemed necessary in order for the content of "/trajectory" to be
> > better defined. Indeed, within some simulation schemes the full trajectory 
> > of
> > the system might include different kind of data.
> > 
> > A rename of "/trajectory" to "/particles" would prevent any such confusion.
> This needs a detailed explanation.
> What kind of simulation schemes and data were you discussing?
> In which cases is /trajectory not appropriate?
> What about simulations without particles, e.g., Lattice-Boltzmann?

This is precisely one of the simulation types that motivated the change. For
now, "/trajectory" holds particle data only. The idea is that if someone doing
Lattice Boltzmann wants to store that it would go in "/fields", "/fluid",
"/lattice_boltzmann", "/whatever". That is not part of the H5MD specification,
it could come later.

> > 2.2 time (in)dependent data
> > 
> > A proposal is made to work in the following way: at any place in the file, a
> > data (such as /trajectory/protein/position) may be either:
> > - A dataset (with shape [N]). It does not depend on time.
> > - A H5MD time-dependent conforming group (see current spec).
> That is a good idea.

Glad to hear that. I am quite prudent about that but it would simplify the

Thanks for your immediate feedback!


> Regards,
> Peter

reply via email to

[Prev in Thread] Current Thread [Next in Thread]