[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

#include bug

From: Tomasz Borowczyk
Subject: #include bug
Date: Wed, 24 May 2023 22:43:51 +0200
User-agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:102.0) Gecko/20100101 Thunderbird/102.11.0

I tried to use GNU Autogen to generate some code for my embedded system project and it works nice unless I try to modularize definitions files and use the #include directive. Here is the example with three files:

params.def file:
ext_param1 = "test ext_param1 successful";

inc.def file:
Autogen definitions inc;
#include params.def
param1 = "param1 test successful";

inc.tpl file:
[+ AutoGen5 template txt +]

The three files above are in the same directory. I have autogen 5.18.16 installed on Ubuntu 22.04.2 with apt install autogen command. When I run :
autogen inc.def
I get:
WARNING: fserr 2 (No such file or directory) performing 'search for' on inc.def
and the output file inc.txt has the following contents:
param1 test successful

When I run the same command on Cygwin on Windows 8.1 I get:
fserr 0: cannot read params.def: No error
Aborted (core dumped)
and no output file.

When I replace the #include directive with:
#shell cat params.def #endshell
I get:
Missing #endshell after '#shell' in inc.def on line 3
(strange because this is in line 2 in inc.def file.

Am I doing something wrong? Is it a bug? I tried to download Autogen 5.19.98 and compile from source and after I run:
I get a lot of errors that look like:
./sys/select.h:744:5: error: #if with no expression

This is all what I have tried.

Best regards,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]