help-cfengine
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: cfd doesn't accept any more connections (1.6.3)


From: Graham Allan
Subject: Re: cfd doesn't accept any more connections (1.6.3)
Date: Wed, 20 Jun 2001 10:53:57 -0600
User-agent: Messenger-Pro/2.50a (Newsbase/0.67c) (RISC-OS/4.02)

In message <address@hidden> you wrote:

> On Wed, Jun 20, 2001 at 12:18:28PM +0200, address@hidden wrote:
> > On 20 Jun, Oliver Cook wrote:
> > 
> > Haven't seen this before, except a while back when the linux
> > pthread library was buggy. Does it help to kill and restart
> > the deamon regularly? (Just an idea...something easy to try)
> > 
> > Mark
> 
> I could try that I guess... I think you're probably onto
> something regarding threading, because the threads in 3.2
> have been improved a lot up to recent 4.3 releases.
> 
> As I say, we can't really upgrade that machine though. Not
> yet anyway.
> 
> I will try what you suggest and get back to you.

I don't know if a "me too" is at all helpful. I see the same behaviour
on our system, running cfd 1.6.2 (I know I should upgrade) on Tru64 UNIX
4.0F.

I think it's not so much related to the length of time it runs, as how
many connections cfd has to service. The interval between the problem
occurring gets shorter as we add more cfengine clients to the network.

Killing cfd and restarting it does always fix it for a while.

Graham
-- 
-------------------------------------------------------------------------
Graham Allan - I.T. Manager - address@hidden - (612) 624-5040
School of Physics and Astronomy - University of Minnesota
-------------------------------------------------------------------------



reply via email to

[Prev in Thread] Current Thread [Next in Thread]