help-cfengine
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Bug w/ cfengine Log, Lock and Repositories directives


From: Mark . Burgess
Subject: Re: Bug w/ cfengine Log, Lock and Repositories directives
Date: Thu, 21 Jun 2001 15:12:56 +0200 (MET DST)

On 21 Jun, Greg Gallagher wrote:
> On Wed, Jun 20, 2001 at 11:05:20PM -0400, Chris Edillon wrote:
>> > So it doesn't seem like I should have to, but for some reason the
>> > binary didn't have them hardcoded even with the configure.
>> > 
>>   which version of cfengine?  IIRC versions prior to 1.6.2 would
>> ignore both compile-time and run-time (cfengine.conf) settings for
>> lockdir and logdir in favor of a hardcoded /etc/cfengine.
> 
> Oh, crudd -- sorry, should have mentioned this.  I'm using version
> 1.6.3 on Solaris 2.6 .... ah, interesting, the compile options seemed
> to have worked in Solaris 2.8 though, or the parsing, because my 2.8
> boxes, compiled from the same 1.6.3 source with the same flags
> mentioned above, didn't spool their last* and log files to
> /etc/cfengine, they put it under /var/run/cfengine as I wanted.  Just
> the 2.6 boxes didn't work (until the conf file re-arranging)
> 


I think there have been some bugs in the locking code. You
could pick up locks.c from the latest 2.0.a11 and that is now
working fine.

Mark

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Work: +47 22453272            Email:  address@hidden
Fax : +47 22453205            WWW  :  http://www.iu.hio.no/~mark
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~





reply via email to

[Prev in Thread] Current Thread [Next in Thread]