[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Need assistance in determining if an rpm is installed

From: Rune Mossige
Subject: Need assistance in determining if an rpm is installed
Date: Tue, 15 Jan 2002 10:22:39 +0100
User-agent: Mutt/1.2.5i

I am working on a stock RedHat 7.2 system, and I would like to set up a
section that will check if some specific RPM's installed. And, if they
are not there, the I want to install them. I am using 2.0.a15.

In my cfagent.conf file, I have:

    have_openmotif-2_1_30-8 = ( "/bin/rpm -q openmotif-2.1.30-8" )

    "/bin/rpm -Uhv /PCgsts001/pc/software/linux/openmotif-2.1.30-8.i386.rpm"

But, it appears that I have not got the syntax correct...I keep getting:
Ccf:WGTS10:/var/cfengine/inputs/cfagent.conf:134: parse error 
cf:WGTS10:/var/cfengine/inputs/cfagent.conf:137: Wildcards cannot be
used in thi
s context: 
cf:WGTS10:/var/cfengine/inputs/cfagent.conf:137: Warning: invalid
cf:WGTS10:/var/cfengine/inputs/cfagent.conf:137: parse error

I have tried to escape the '.', and tried single-quotes, without much

What is the correct way of doing this?

           (-: Hiroshima 45, Chernobyl 86, Windows 95 :-)
Our ultimate goal is to make overloaded systems appear to be idle.
High performance, High reliability, Low cost -------- Pick any two.
Rune  Mossige,  Systems  Support  Engineer,  WesternGeco, Stavanger
Tel: (+47)51946869                             Mobile:(+47)90871024

reply via email to

[Prev in Thread] Current Thread [Next in Thread]