help-cfengine
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: binaries of cfengine


From: Thomas Glanzmann
Subject: Re: binaries of cfengine
Date: 2 Jan 2003 13:04:56 GMT
User-agent: slrn/0.9.7.4 (Linux)

> I'm having lot of trouble compiling cfengine for Solaris ( 5.8 )  & 
> Linux ( 7.1/7.3 )
It is not that hard. If you want I can provide my compile scripts for both.

> Does anyone have static compiled versions of cfengine for those platforms ?
I could make you one for Linux. But the last time I tried it keeps crashing
after some big file transer (kde-3.0 (about 10.000 files)). For Solaris it is
impossible to provide a static linked version because the thread library and
parts of libc are only avaiable for dynamic linking.

If you're interested in scripts or in binaries just drop me an eMail.

For the solaris version I compiled openssl, libdb static into cfengine.

And one last tip. If you want to use cfengine under solaris get sure that you
got the /dev/{u,}random Kernel patch for Sol 5.8. If you have Sol 5.9 it comes
out of the box.

Greetings,
        Thomas
-- 
Rathsbergerstrasse 28     D-91054 Erlangen / Burgberg     +49 (0) 9131 - 614720
>From address@hidden Thu Jan 02 13:27:36 2003
Received: from list by monty-python.gnu.org with tmda-scanned (Exim 4.10.13)
        id 18UA3V-00074z-00
        for address@hidden; Thu, 02 Jan 2003 13:26:57 -0500
Received: from mail by monty-python.gnu.org with spam-scanned (Exim 4.10.13)
        id 18UA1N-0006F8-00
        for address@hidden; Thu, 02 Jan 2003 13:24:48 -0500
Received: from mailrelay.udlp.com ([207.109.1.10])
        by monty-python.gnu.org with esmtp (Exim 4.10.13)
        id 18U9xN-00050V-00
        for address@hidden; Thu, 02 Jan 2003 13:20:38 -0500
Received: from asdmngwia.mpls.udlp.com (asdmngwia.mpls.udlp.com [10.1.62.22])
        by mailrelay.udlp.com (8.12.6/8.12.6) with ESMTP id h02IKTDG021494
        for <address@hidden>; Thu, 2 Jan 2003 12:20:30 -0600
Received: from DM-MN-06-MTA by asdmngwia.mpls.udlp.com
        with Novell_GroupWise; Thu, 02 Jan 2003 12:20:25 -0600
Message-Id: <address@hidden>
X-Mailer: Novell GroupWise Internet Agent 6.0.1
Date: Thu, 02 Jan 2003 12:20:21 -0600
From: "Ryan Anderson" <address@hidden>
To: <address@hidden>
Mime-Version: 1.0
Content-Type: text/plain; charset=US-ASCII
Content-Transfer-Encoding: 7bit
Content-Disposition: inline
Subject: module output becomes an actionsequence?
X-BeenThere: address@hidden
X-Mailman-Version: 2.1b5
Precedence: list
List-Id: Users list for GNU cfengine  <help-cfengine.gnu.org>
List-Help: <mailto:address@hidden>
List-Post: <mailto:address@hidden>
List-Subscribe: <http://mail.gnu.org/mailman/listinfo/help-cfengine>,
        <mailto:address@hidden>
List-Archive: <http://mail.gnu.org/pipermail/help-cfengine>
List-Unsubscribe: <http://mail.gnu.org/mailman/listinfo/help-cfengine>,
        <mailto:address@hidden>
X-List-Received-Date: Thu, 02 Jan 2003 18:27:39 -0000

I have a home-made cfengine module written in shell that finds out which
NIS domain a system is on and I can not get it to work with a config
file I am creating. The module works elsewhere, but when I use it in
conjunction with a variable, it puts the variable in as an
actionsequence, then fails. This is running on Solaris 8. Its called
module:mydomainname. It simply contains:

################
#!/bin/sh

domain=`domainname`

if [ x$domain != "x" ]; then
        echo "+dom_$domain"
fi
################


In a cfengine config file I'm testing this with, I want to figure out
which of three domains a system is on and copy files to it based on
this, it is invoked with:

actionsequence = (
module:mydomainname.dom_firstdomain.dom_secondomain.dom_thirddomain copy
)

Also in the control section I define which file to copy, this is where
the problem seems to occurr. In this case, I want to copy the file
firstdomain_solaris to this system:

solaris.dom_firstdomain::
 cf_file  = ( /local/cfengine/files/firstdomain_solaris )

In the copy section, I do this:

copy:
            $(cf_file)
                                  dest=/var/cfengine/indir/cffile
                                  o=root
                                  server=$(policyhost)
                                  trustkey=true


When I run cfengine from the command line on a client system, with
'cfagent -d 3 -q > /tmp/foo', it is shows this in the output:

*************
Action sequence = (files editfiles processes tidy links
module:mydomainname.dom_firstdomain.
dom_seconddomain.dom_thirddomain copy
/local/cfengine/files/firstdomain_solaris )
......
DEFINED FILE IMAGES
${cf_file}
 +400
 -7377
 dest: /var/cfengine/indir/cffile
......
*********************************************************************
 Main Tree Sched: /local/cfengine/files/firstdomain_solaris pass 1 @
Thu Jan  2 11:06:21 2003
*********************************************************************

No action matched /local/cfengine/files/firstdomain_solaris
*(last line of output)
*************


My REAL question: Why is the file I want to copy, which is correctly
determined; ie it IS finding out which domain its on, becoming an
actionsequence? This is causing it all to fail. I'd rather avoid making
a separate copy statement for each different domain & OS!


Thanks,

RCA
--
Ryan C. Anderson
Unix Administrator
United Defense L.P.
desk   763.572.6684
pager 952.235.9936
mobile 612.419.9362



reply via email to

[Prev in Thread] Current Thread [Next in Thread]