help-cfengine
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: module output becomes an actionsequence?


From: Luke A. Kanies
Subject: Re: module output becomes an actionsequence?
Date: Tue, 14 Jan 2003 16:43:58 -0600 (CST)

On Tue, 14 Jan 2003, Hugo Gayosso wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> "Luke A. Kanies" <address@hidden> writes:
>
> > This cuts out the module, which will probably simplify things enough that
> > you can get it all to work.  I don't really know why cfengine doesn't
> > support pipes in ExecResult, but when I tried 'domainname | sed 's/\./_/g'
> > it tried to set my domainname.
>
> Try with:
>
> /bin/sh -c "/bin/domainname | /bin/sed 's/\./_/g'"

I tried that and it still didn't work.  As far as I can tell, cfengine
just doesn't support pipes in ExecResult.

I could just be retarded, though.  This is what I have:

control:
   variable = ( ExecResult(/bin/domainname | /bin/sed 's/m/n/') )
   actionsequence = (
      shellcommands
   )

shellcommands:
   "/bin/echo ${variable}"

----

This tries to set my domainname on solaris.

-- 
Today I dialed a wrong number...The other person said, "Hello?" and
I said, "Hello, could I speak to Joey?"...
They said, "Uh...I don't think so...he's only 2 months old."
I said, "I'll wait."  -- Steven Wright




reply via email to

[Prev in Thread] Current Thread [Next in Thread]