help-cfengine
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: 2.0.4 Connections Dying


From: Brian E. Seppanen
Subject: Re: 2.0.4 Connections Dying
Date: Tue, 28 Jan 2003 13:22:23 -0500 (EST)

Doing a debug of an update that hangs gives me the following

***Closing socket 5 from 192.168.0.1
Deleted item 192.168.0.1
IPV4 address
sockaddr_ntop(192.168.0.1)
Obtained IP address of 192.168.0.1 on socket 5 from accept
FuzzyItemIn(192.168.0.1)
FuzzyItemIn(192.168.0.1)
Purging Old Connections...
Done purging
FuzzyItemIn(192.168.0.1)
Prepending 192.168.0.1

And nothing thereafter....  The logs don't even show the decrypt error.



On Tue, 28 Jan 2003, Brian E. Seppanen wrote:

> Hi Folks:
> 
> I've had a couple of occurances where cfengine 2.0.4 on redhat linux 7.3
> or 7.2 has hung, and stopped responding.  Basically my update never
> completes.  The wierd thing is that the update I'm doing is the same one I
> did fifteen minutes previously and it worked just fine.  I've killed the
> cfengine process on the box from which I trigger it, and I've killed
> cfservd on the box that it appears hung on.  What has happened is that the
> socket appears to be wedged in that it stays in a close_wait state
> forever, and I cannot start a new daemon.  I've left it that way for a
> weekend, and it never closes.  My only recourse was to reboot the box,
> which I really hate to do.  What might be causing this?  
> 
> I did get this message in my logs
>                                     Private decrypt failed = block type is 
> not 02 
> Jan 28 09:14:32 HOST cfservd[3502]: Host authorization/authentication failed 
> or access denied
> 
> This is the same host authentication that worked about 15 minutes 
> previously.
> 
> In this situation killing cfservd freed up the socket, and I was able to 
> restart, but I have had two situations on a low memory host where the 
> socket was never freed and I had to reboot.
> 
> Anyone know of a way to force the socket closed without resorting to a 
> reboot?   
> 
> Thanks,
> 
> Brian Seppanen
> address@hidden
> 906-228-4226 ext 23
> 
> 

Brian Seppanen
address@hidden
906-228-4226 ext 23





reply via email to

[Prev in Thread] Current Thread [Next in Thread]