help-cfengine
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: cfservd dying


From: Ryan Anderson
Subject: Re: cfservd dying
Date: Wed, 12 Mar 2003 16:39:33 -0600

While I haven't done this with cfservd yet, you could wrap cfservd in
/etc/inittab with the 'respawn' option so that it will respawn the
process if it ever dies. Anyone try this with cfservd? Any problems with
it?

RCA
--
Ryan C. Anderson
Unix Administrator
United Defense L.P.
desk   763.572.6684
pager  952.235.9936
mobile 612.419.9362

>>> Yves <address@hidden> 03/12/03 04:15PM >>>
>Subject: cfservd dying
>From: paguerlais airfrance.fr
>Date: Wed, 11 Sep 2002 17:30:57 +0200
>Newsgroups: gmane.comp.sysutils.cfengine.general
>Sensitivity: 
>
>
>Hi all,
>
>it seems to me that somebody already mailed about that, but I can't
find
>out again that damned thread ;-)
>
>I'm running cfengine 2.0.4 on a RedHat 7.1 box, and trying to use
cfrun
>from the same box to execute its cfagent. cfservd starts the
connection
>with cfrun, but dies somewhat later. This happens only when cfrun is
>executed on the same box than the cfservd it must contact.
>If I run cfservd in debug mode, I can see that the authentication
process
>seems ok, but thereafter cfservd dies with the following messages :
>
>IPV4 address
>sockaddr_ntop()
>Address family was 1
>my_host.my_domain::Software failure in sockaddr_ntop
>
>ReleaseCurrentLock(cfservd)
>failed
>
>
>Does somebody has already seen this ?
>
>Attn Mark : you used the same message (software failure in
sockaddr_ntop)
>in two functions, sockaddr_ntop and sockaddr_pton. Perhaps you've
forgotten
>to change the function name for the second one ?
>
>Thanks
>Patrice
 
Hi Patrice,
 
I have the same problem. My cfservd dies very often.
I tried (for the first time) "cfservd -d 2" on cfengine master:
 

cfservd Debug mode: running in foreground
GetNameInfo()
AddClassToHeap(aix)
Appending [aix]
....
Host IPs from NAT which we don't verify :
 
IP: xx.xx.82.215
Dynamical Host IPs (e.g. DHCP) whose bindings could vary over time :
 
Address family was 0
cfmaster::Software failure in sockaddr_ntop
 
ReleaseCurrentLock(cfservd)

 
and cfservd doesn't start.
 
If I start cfservd without options it works and ca. 800 clients contact
the cfengine master every half an hour. But as mentioned above the
cfservd dies very often (ca. every other day) without any hints in
SYSLOG.
 
How can I analyze it ?
Does anybody have an idea ? Is it an compiling problem ?
 
basic conditions:
AIX 4.3.3
cfengine v2.0.4
 
Gruß Yves
 
address@hidden am 12.03.2003




reply via email to

[Prev in Thread] Current Thread [Next in Thread]