help-cfengine
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Error when installing: BerkeleyDB not found, even though it's insta


From: Frank Smith
Subject: Re: Error when installing: BerkeleyDB not found, even though it's installed
Date: Thu, 20 Mar 2003 12:56:53 -0600

Is /usr/local/BerkeleyDB.4.1 in your /etc/ld.so.conf and did you run ldconfig ?

Frank

--On Thursday, March 20, 2003 19:35:56 +0100 Johan Ho <address@hidden> wrote:

When I run
"./configure --prefix=/danton/usr --sysconfdir=/danton/etc/cfengine" the
configuration is stopped by these msgs:
    checking for BerkeleyDB location... /usr/local/BerkeleyDB.4.1
    checking Berkeley DB Version... configure: error: This release of
cfengine requires BerkeleyDB 3.2 or later.

In config.log it says: (extract)
    configure:3474: checking for BerkeleyDB location
    configure:3527: result: /usr/local/BerkeleyDB.4.1
    configure:3546: checking Berkeley DB Version
    configure:3570: gcc -o
conftest -g -O2 -I/usr/local/BerkeleyDB.4.1/include
    -L/usr/local/BerkeleyDB.4.1/lib conftest.c -lm  -ldb >&5
    configure:3573: $? = 0
    configure:3575: ./conftest
    ./conftest: error while loading shared libraries: libdb-4.1.so: cannot
open shared object file: No such file or directory

However, when I go to the path /usr/local/BerkeleyDB.4.1/lib, the file
libdb-4.1.so is indeed there!
Is there anything else I should check before doing the configure?
I'm running in Debian, in any case.

Johan Ho
Student in class 2AD, HiO IU






reply via email to

[Prev in Thread] Current Thread [Next in Thread]