help-cfengine
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Problems with Editfiles and Creating File


From: Brian E. Seppanen
Subject: Problems with Editfiles and Creating File
Date: Wed, 26 Mar 2003 13:24:25 -0500 (EST)

I'm running cfengine 2.0.5pre2. and I'm having a problem with a file being 
created using cfengine.   Basically I get the following output when 
running cfengine, and the file is never created.   What might I be 
missing?


cfengine:host:in/cfagent -f /: cfengine:host:in/cfagent -v -: 
cfengine:host: Lock 
lock._var_cfengine_inputs_cf_host.host.editfile._tmp_procmailrc 
expired...(after 2/2 minutes)
cfengine:host:in/cfagent -f /: 
cfengine:host:in/cfagent -v -: Trying to kill expired proc

After the trying to kill expired proc it moves onto the shellcommands 
portion of the cf file, and the file is never created.   I have the 
following.   I've tried it with AutoCreate, and without AutoCreate.   I've 
tried editing a zero length file.   I've tried it without the Umask.   
I've tried it without Syslog, and I don't see any syslog output at all.   

I've tried it with AppendIfNoSuchLine, instead of InsertLine's and no 
Group definitions.   I need to find a way to handle file creation.



        { /tmp/procmailrc
                Syslog "true"
                Umask 640
                AutoCreate
                BeginGroupIfNoMatch "VERBOSE=off"
                        IncrementPointer "-1"
                        InsertLine "VERBOSE=off"
                        InsertLine "MAILDIR=/home/test/mail"
                EndGroup
        }

Any help greatly appreciated.

Thanks,


Brian Seppanen
address@hidden
906-228-4226 ext 23





reply via email to

[Prev in Thread] Current Thread [Next in Thread]